Jump to content

Kronos X 61 Key and Logic Pro 9 conflict


joeydiamondz

Recommended Posts

Hello, first off i would like to say i just purchased the Kronos X 61 keys roughly a month ago, and i have it plugged in to my computer thru USB. I use Logic Pro 9 to make all of my productions and i bought the kronos to use its sounds on logic as an external midi track so i can edit the sound i played through Logic's piano roll and interface. If i set up an audio track and click record, i can hear the kronos on playback. But if i open an external midi track, and set the port to KRONOS SOUND, it just reads the keys i am touching but no sound comes out. I can even record the notes I play and see them on the piano roll. BUT no sound while im playing the keys and no sound when i play what i recorded. I am hoping there is something simple i didnt do so i can fix this puzzle. BTW, I tried hooking it up only midi in/out with my interface (babyface), but then that doesnt even let Logic recognize the kronos at all, not even recieve midi data. I hope the Kronos doesnt need to get returned. I am dying to hear back from someone with a miracle solution, thank you so much.

-Joey

Link to comment
Share on other sites

Hello and welcome to Logic Pro Help. To make troubleshooting your issue easier, please click this link to your signature and add your system information:

 

• Logic version and sub-version (e.g. Logic 10.0.5)

• OS X version and sub-version (e.g. OS 10.9.1)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2 GHz Intel Core 2 Duo)

• Memory (e.g. 2GB)

• Audio interface manufacturer and model (e.g. Presonus AudioBox USB)

• MIDI Controller manufacturer and model (e.g. M-Audio Axiom Pro 49)

 

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

 

Are you planning to get the Kronos' audio into Logic via its USB port or through the Babyface's inputs (using audio cables)? Whichever it is, you need to set it as the input device in Logic's audio preferences.

 

J.

Link to comment
Share on other sites

Hello and welcome to Logic Pro Help. To make troubleshooting your issue easier, please click this link to your signature and add your system information:

 

• Logic version and sub-version (e.g. Logic 10.0.5)

• OS X version and sub-version (e.g. OS 10.9.1)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2 GHz Intel Core 2 Duo)

• Memory (e.g. 2GB)

• Audio interface manufacturer and model (e.g. Presonus AudioBox USB)

• MIDI Controller manufacturer and model (e.g. M-Audio Axiom Pro 49)

 

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

 

Are you planning to get the Kronos' audio into Logic via its USB port or through the Babyface's inputs (using audio cables)? Whichever it is, you need to set it as the input device in Logic's audio preferences.

 

J.

 

 

 

Hey Jordi THANK YOU so much for your reply and interest to helping me, i am in desperate need. This is my reply to what you asked me.

 

-Logic version and subversion=9.1.8 (1700.67) (32-bit)

-OS X Lion 10.7.5

-iMac

-Processor 2.5 GHz Intel Core i5

-Memory is 4 GB 1333 MHz DDR3

- My audio interface is the Babyface which uses RME Fireface USB Settings (Version 1.58)

-My Midi Control is the Korg Kronos X 61 Key

Link to comment
Share on other sites

Hey Jordi THANK YOU so much for your reply and interest to helping me, i am in desperate need. This is my reply to what you asked me.

 

-Logic version and subversion=9.1.8 (1700.67) (32-bit)

-OS X Lion 10.7.5

-iMac

-Processor 2.5 GHz Intel Core i5

-Memory is 4 GB 1333 MHz DDR3

- My audio interface is the Babyface which uses RME Fireface USB Settings (Version 1.58)

-My Midi Control is the Korg Kronos X 61 Key

 

Cool! Now please add it to your signature so that the info appears at the bottom of all your posts. Click the blue link from my previous post to go to edit your signature.

 

Thanks you.

 

J.

Link to comment
Share on other sites

Hey Jordi THANK YOU so much for your reply and interest to helping me, i am in desperate need. This is my reply to what you asked me.

 

-Logic version and subversion=9.1.8 (1700.67) (32-bit)

-OS X Lion 10.7.5

-iMac

-Processor 2.5 GHz Intel Core i5

-Memory is 4 GB 1333 MHz DDR3

- My audio interface is the Babyface which uses RME Fireface USB Settings (Version 1.58)

-My Midi Control is the Korg Kronos X 61 Key

 

Cool! Now please add it to your signature so that the info appears at the bottom of all your posts. Click the blue link from my previous post to go to edit your signature.

 

Thanks you.

 

J.

 

 

 

Perfect, got it up now. Hopefully someone can help me with my issue here I am at a dead end and need help desperately with this. Thank you so much!

Link to comment
Share on other sites

SORRY i didnt see your last question! I have it hooked up through USB port. And now i managed to get the Kronos' sounds to play while having an external midi track opened and having the port in Logic set to KRONOS SOUND, i can play and record audio/midi data and see it on the piano roll. Now the only issue remaining is the midi sound ITS ONLY COMING OUT OF MY LEFT MONITOR! haha I am stuck now here, this must be a simple fix now that i am closer to fully utilizing the kronos together with logic! Hoping for an answer THANK YOU!
Link to comment
Share on other sites

I think you missed my question from my first reply to you:

 

Are you planning to get the Kronos' audio into Logic via its USB port or through the Babyface's inputs (using audio cables)? Whichever it is, you need to set it as the input device in Logic's audio preferences.

 

J.

 

And just so you know those were the device preferences in logic. All the other sounds that i recorded and created with logic's system instruments are playing properly through both monitors, its only the external midi track that is set to the kronos is whats playing through the left monitor only. Besides that, it is properly playing/recording onto logic no problem, just needs to come out both speakers. Hope you can help J.

Link to comment
Share on other sites

Now the only issue remaining is the midi sound ITS ONLY COMING OUT OF MY LEFT MONITOR!

 

Sounds like you're monitoring a mono input through a stereo channel strip in Logic? Are you able to set how the audio is output through the USB port in the Kronos (mono vs stereo)? If you plug a set of headphones in its headphones out, do you hear sound in both channels?

 

J.

Link to comment
Share on other sites

  • 2 weeks later...
Now the only issue remaining is the midi sound ITS ONLY COMING OUT OF MY LEFT MONITOR!

 

Sounds like you're monitoring a mono input through a stereo channel strip in Logic? Are you able to set how the audio is output through the USB port in the Kronos (mono vs stereo)? If you plug a set of headphones in its headphones out, do you hear sound in both channels?

 

J.

 

 

It was working like that one day, and when i plugged in the headphones in the kronos it came out of both headphones. But when I plugged into my interface the headphones wouldn't play, only sound I heard was coming out of the left monitor. And now when I try, I don't get any sound, it recieves signal but no sound. I can play Logic's softward instruments, but I cannot use my kronos correctly as an external midi. Is there something I missed out?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...