Jump to content

What's wrong with snap automations in lpx?


Recommended Posts

i have a track, i want to make a mute automation exactly at while i'm zoomed out (i can see about 40 measures on arrange), i have snap automation enabled and is on auto:


- double click, automation is perfectly at (it takes care of the automation option of 4 ticks)


the snap in logic is more precise, so at the same level of zoom, where in logic 9 it was a bar snap, in logicx it snaps also to the beats, or even the 16th with higher zooms!! so it happens many times that my new freshly made automation is not where i want.

now let's say i did a wrong click and the automation is at, if i want to move that automation forward by 1 beat:


logic 9

- just drag (it won't even happen cause the snap was much better configured)

logic 10

- the moment i try to move it it lose the snap and it goes to a random value, sometimes is .23 some others .153 etc.. (probably it depends of where i have clicked)

Also, if i release the mouse i've lost the snap anyway, i have to delete the automation and make a new one.

In addition to that i have a graphical bug, the automation flashes continuously while moving, jumping from the current position to the future position. if i don't move the mouse it let me see the old position not the new.


Basically i have to zoom now to make a snapped automation and i can't move those else i lose the snap.


this has to be fixed, please confirm this, i'm on 10.0.6 and 10.8.5.

i can screenshot if something is not clear.

Link to comment
Share on other sites

Ok i've made some photos, i can't believe that it's not working only for me.

this is driving me mad honestly and i'm wasting a lot of time because of this.


1 - make a new project

2 - make a new inst track

3 - enable automation with "smart" and "snap automation"




4 - make some mute automation on measures, you can see if i click on a point that the value is correct




5 - now select all the automation and move them, the snap is lost and the .236 tick changes with another random value




6 - every time i click again and move the last tick value changes




am i alone?

Link to comment
Share on other sites

  • 4 weeks later...
Snap automation doesn't follow the Snap settings. I'm not sure wether it's by design or a bug? It also doesn't snap when dragging existing control points, instead, it snaps when creating new control points. The snapping is either on the division or the beat, depending on your zoom level.
Link to comment
Share on other sites

well, it works fine with all the other automatons i've tried so far, it gives problems only with mute automations, if snap it set to smart automation will follow right, and if i move automations it retains their relative position, it does not work only with mutes as Eric pointed out
Link to comment
Share on other sites

well, it works fine with all the other automatons i've tried so far

Ok you're right: when I said it only snaps when creating, not when dragging, that was only for the Mute parameter.


But other than that, automation doesn't follow the Snap settings: with Volume automation for example, if you try to move a volume control point while the Snap mode is set to Bar, it continues snapping on the beat or division depending on your zoom level.

Link to comment
Share on other sites

  • 10 months later...
  • 7 months later...

Man, is this still an issue? I've got Logic Pro 10.2.0...this is what's happening with an Insert Bypass...


I figured a work around for regions by placing the playhead where I want it then pressing ";"...but this is unbelievable. Sure you don't need your automation to be 100% perfect, but still seems like a pretty basic function that should work properly...especially in a new update.


Won't even snap to the beat or division either...I have the division set to /4 and no dice...




NOTE: I have "Snap To Grid" enabled, but I couldn't get it in the gif creator view...I should have just moved the LPX window down, but didn't think about that until after. Also, I tried with and without Alignment Guides and the other options and it still doesn't work.



Link to comment
Share on other sites

  • 3 weeks later...
In the mean time I've found that you can use the Automation Event List (CMD + E + Shift+), then when you click on the node it'll highlight it in that AEL window. Then just type in where you want it. Hope that helps, man!

Isn't it easier to just create a new node? (those do snap)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...