Jump to content

iRig - Logic Pro X


MrUkris

Recommended Posts

Hello there, I want to record my bass guitar directly with my iMac, I'm tired transferring from iPad to iMac and stuff.

I connected it and couldn't be able to monitor the sound. Even I use the iRig's input for headphone. How can I monitor it, doesn't matter if I will hear the sound through the speakers?

Thanks and sorry for my bad English.

Link to comment
Share on other sites

I don't know why you are hearing noise.

Is it happening even if you unplug the bass?

No, It's happening when I play it. I don't know the name of it but it happens like when you face the mic to the amp in the studio.

Edit: I'm playing bass for about a week, never played a string instrument before and this is what I made with iRig on Garageband for iPad: https://soundcloud.com/uniquejam/valentines-distortion

Link to comment
Share on other sites

No, you got me wrong. I made that with Garageband for iPad. I'm not "that" noob. -_-

The problem is when I plug the iRig into my iMac's headphone, and touch a string (even I use a clean amp), it gives noises like I turned a microphone against the amp.

BTW I used Seattle Sound amp with fuzz pedal for the distortion. (Garageband)

Link to comment
Share on other sites

>>it gives noises like I turned a microphone against the amp.<<

I think he is trying to discribe "feedback"

 

>> touch a string (even I use a clean amp), it gives noises like ...<<

But based on this statement, I'd say he either has a ground loop causing 60 cycle hum when he closes the loop by touching the string, or the pickups are picking up hi-frequency "signal" from the iMac's video monitor.

 

Facing away from or at least at an angle to the video monitor and adding a little distance from the iMac while playing, would help with the 2nd problem.

 

Not sure what would be the best solution to a ground loop involving an iRig. Usually a DI box would help.

Link to comment
Share on other sites

  • 4 years later...
I bought an iRig2 and tried it out with my Logic Pro X. It used to play well beside the noise mentioned by MrUkris. However couple weeks ago i tried to hook it up as I used to and now the device wont send signal to logic. I connect the cables and there is no sign of logic getting the signal from the iRig, which is weird cause it used to connect no prob. I tried all the audio setting and still nothing. Funny thing it works well with garageband on my iphone O.o
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...