Jump to content

The crashes just keep coming...LPX, on playback


strikingtwice

Recommended Posts

Really rough weekend. This is a recurring one that seems more problematic. Just happens on playback. No tells. Project is really stripped down as i've been trying to isolate. Tried turning off interface and using built in, tried killing prefs...

 

I've tried searching this "Application Specific Information:

*** error for object 0x7fb211bd6808: incorrect checksum for freed object - object was probably modified after being freed."

with no great results. Some stuff has come up on the apple forum but it really seems pretty general.

 

Process:         Logic Pro X [12509]
Path:            /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X
Identifier:      com.apple.logic10
Version:         10.0.6 (3130.20)
Build Info:      MALogic-3130020000000000~1
App Item ID:     634148309
App External ID: 283213010
Code Type:       X86-64 (Native)
Parent Process:  launchd [182]
User ID:         501

Date/Time:       2014-02-25 07:20:56.848 -0500
OS Version:      Mac OS X 10.8.5 (12F45)
Report Version:  10

Interval Since Last Report:          143465 sec
Crashes Since Last Report:           1
Per-App Interval Since Last Report:  2213 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      31529E0D-7E6D-4E14-A603-AC21CDEB7FFA

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
*** error for object 0x7fb211bd6808: incorrect checksum for freed object - object was probably modified after being freed.


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8f752212 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff9873db24 pthread_kill + 90
2   libsystem_c.dylib             	0x00007fff98781f61 abort + 143
3   libsystem_c.dylib             	0x00007fff9875d8d5 szone_error + 580
4   libsystem_c.dylib             	0x00007fff98763997 small_malloc_from_free_list + 494
5   libsystem_c.dylib             	0x00007fff98763436 szone_malloc_should_clear + 3321
6   libsystem_c.dylib             	0x00007fff98755183 malloc_zone_malloc + 71
7   com.apple.CoreFoundation      	0x00007fff9a0f445f __CFBasicHashRehash + 383
8   com.apple.CoreFoundation      	0x00007fff9a111cfd __CFBinaryPlistWrite + 173
9   com.apple.CoreFoundation      	0x00007fff9a111c22 CFPropertyListWrite + 594
10  com.apple.CoreFoundation      	0x00007fff9a10fee7 CFPropertyListCreateData + 327
11  com.apple.Foundation          	0x00007fff98360b52 +[NSPropertyListSerialization dataWithPropertyList:format:options:error:] + 37
12  com.apple.Foundation          	0x00007fff98360a96 -[NSKeyedPortCoder _buildMainData] + 86
13  com.apple.Foundation          	0x00007fff98360a0f -[NSKeyedPortCoder finishedComponents] + 25
14  com.apple.Foundation          	0x00007fff9835bba8 -[NSConnection _sendBeforeTime:coder:doAuthenticationCheck:] + 85
15  com.apple.Foundation          	0x00007fff98358dcd -[NSConnection sendInvocation:internal:] + 1309
16  com.apple.CoreFoundation      	0x00007fff9a161197 ___forwarding___ + 775
17  com.apple.CoreFoundation      	0x00007fff9a160e18 _CF_forwarding_prep_0 + 232
18  com.apple.HIToolbox           	0x00007fff95b63d46 -[IMKInputSession activate] + 169
19  com.apple.HIToolbox           	0x00007fff95b28788 IMKInputSessionActivate + 36
20  com.apple.HIToolbox           	0x00007fff95b27da7 ActivateInputMethodInstance + 65
21  com.apple.HIToolbox           	0x00007fff95b20b42 utOpenActivateSelectedInputMethodInDoc + 135
22  com.apple.HIToolbox           	0x00007fff95b20a9b utOpenActivateAllSelectedIMInDocIterator + 21
23  com.apple.CoreFoundation      	0x00007fff9a110154 CFArrayApplyFunction + 68
24  com.apple.HIToolbox           	0x00007fff95987ce1 utOpenActivateAllSelectedIMInDoc + 191
25  com.apple.HIToolbox           	0x00007fff959829ef MyActivateTSMDocument + 1590
26  com.apple.HIToolbox           	0x00007fff959823b4 ActivateTSMDocument + 9
27  com.apple.AppKit              	0x00007fff94a484e8 -[NSTextInputContext activate] + 191
28  com.apple.AppKit              	0x00007fff94976458 +[NSTextInputContext currentInputContext] + 294
29  com.apple.AppKit              	0x00007fff94975b81 -[NSApplication updateWindows] + 94
30  com.apple.AppKit              	0x00007fff94bc0d9f __38-[NSApplication setWindowsNeedUpdate:]_block_invoke_02349 + 76
31  com.apple.CoreFoundation      	0x00007fff9a139417 __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 23
32  com.apple.CoreFoundation      	0x00007fff9a139381 __CFRunLoopDoObservers + 369
33  com.apple.CoreFoundation      	0x00007fff9a1147b8 __CFRunLoopRun + 728
34  com.apple.CoreFoundation      	0x00007fff9a1140e2 CFRunLoopRunSpecific + 290
35  com.apple.HIToolbox           	0x00007fff95975eb4 RunCurrentEventLoopInMode + 209
36  com.apple.HIToolbox           	0x00007fff95975b94 ReceiveNextEventCommon + 166
37  com.apple.HIToolbox           	0x00007fff95975ae3 BlockUntilNextEventMatchingListInMode + 62
38  com.apple.AppKit              	0x00007fff94974533 _DPSNextEvent + 685
39  com.apple.AppKit              	0x00007fff94973df2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
40  com.apple.AppKit              	0x00007fff9496b1a3 -[NSApplication run] + 517
41  com.apple.AppKit              	0x00007fff9490fbd6 NSApplicationMain + 869
42  com.apple.logic10             	0x00000001024d7655 0x10201b000 + 4965973
43  libdyld.dylib                 	0x00007fff8fe437e1 start + 1

Link to comment
Share on other sites

Ok, so i took ozone off, still got the crash. I'm going to post the whole thread now instead of just hte crashed thread. I was poring over this and can anyone offer any suggestions why there are a billion NI Rig kontrol related threads? I'm using a bunch of guitar rigs, but i don't even use that. annoying.
Link to comment
Share on other sites

ok. Here's what i've tried so far.

 

Reinstalled mavericks. Pretty smooth and everything seems working, but same project is still crashing.

 

Imported everything into a new project and stripped out EVERYTHING. It's literally just playing back audio. No plugs, no busses, nothing.

 

I thought it might be bad blcoks on the drive (though it passes smart), i moved the folder to another disk and played it off of that instead. Still crashes.

 

On a hunch, i dragged my aduio folder into Sample Manager. Quite a few of the files came up as damaged. Repaired them all, thinking maybe that was it. Nothing.

 

My next nuclear option is to reinstall logic, but i'm not sure what that would even do. These app packages are so tight anymore especially with the whole app store integration, i'm not entirely convinced it will do anything. I've been able to work in other stuff mostly with infrequent crashes, but this project/new project are killing me. it's only about 4 minutes long. I'm running at max buffer thinking it was a cpu issue but it crashes just the same. Running out of ideas.

 

I did permissions if anyone's going to ask, but that is never to actually solve anything, it's just to tell people you repaired permissions in case they ask.

Link to comment
Share on other sites

Man...Flex pitch. It was flex pitch. It didn't occur to me that that was still on and when I gave it to my friend via gobbler he also got the crashing which was awesome, It relieved me that it wasn't something deep on my computer. Anyway, with flex pitch off, I have been able to play to the end.

 

Any idea why that would be a thread 0 crash? That seems way too low for something like that. Not sure. Anyway, I'm pretty sure that's it. i've had a few successful playthroughs. It bums me, but I suppose i'll just have to flex and bounce all the time. a hassle i suppose. But i'm just happy i got to the bottom of it. I was at wit's end. Any suggestions?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...