Jump to content

Cannot control assign faders correctly tracks in mixer view


mhinojosa

Recommended Posts

OS: Mac OS X 10.9.2

DAW: Logic Pro X

Midi controller: Edirol PCR 500

 

I'm having a very puzzling problem with assigning fader controls to my midi keyboard. Basically whenever I try to do control assignment in any project, other than a fresh empty project, the faders in the mixer view are not assigned correctly. The problem goes something like this:

 

I open a new template, or a ongoing project, then open the Controller Assignment window and select the fader of track 1 in the mixer view and then press "Learn Mode" and then move the corresponding fader in my keyboard. Much to my surprise, the fader that responds to the mapping is not the one from track 1, but rather track 3. If I do the same for track 2 then the fader that responds in logic is track 4. this n+2 pattern is repeated across all faders in the mixer view. However, if I start a completely empty project, this "jumping" problem does not occur....

 

Any ideas as to why this happens??

Link to comment
Share on other sites

Ok, so I decided to remove my user and control preferences from the Preferences folder ( the com.apple.logic10.plist and com.apple.logic.pro.cs files). After restarting my Mac I found that doing the fader assignments worked properly (i.e. the virtual fader I selected is the one that responds to changes in my midi controller). However, I noticed that when I try creating an assignment that allows moving a group of faders by one position to the right or left, the problem I mentioned before come back!. This makes me believe that the way I'm setting the group assigment is somehow messing with the individual fader assigment....

 

The way I built the movement of a group of faders was in the following way (I followed a YoutTube video):

In Controller Assignment window, I assigned a midi button to transpose position by one unit with the following characteristics:

Class: Control Surface Group

Parameter: Fader Bank for Tracks View

Bank type: By One

Min/Max: 0 - 5 (i.e. same number of individually assigned faders)

Format: unsigned

Multiply: 1.00

Mode: Rotate

 

I then created another button that goes the opposite way. the configuration is the same with the exception of the multiply parameter, which was set to -1.00

 

So, when I start playing with these new "position transpose" buttons I don't seem to get the outcome I want (moving a group of faders by one unit) and worse, I get my individual faders messed up even when I delete all the learned assigments and try to do it all from scratch. It seems some sort of memory is built which can only be deleted by removing user and control surface preferences....

 

 

Does any one know why this setting is messing up with my faders?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...