Jump to content

No easier way to achieve Local MIDI OFF?


Recommended Posts

I have an external Yamaha P155 piano that I use for midi and audio recording in Logic; it sounds and feels more real during recording than any of Apple's EXS pianos, AU virtual pianos, and/or Kontakt Pianos (and I have tried scads of them over the years!)


For the longest time, I had local MIDI turned off on the piano so not to get double note playback from the keypress and MIDI return (as per the previous Double Midi Notes thread viewtopic.php?p=372189)


Now, however, I have a 3-year old who needs to be able to sit down, turn the piano on and start playing without fishing through Yamaha's torturous MIDI settings buttons to play.


I can't believe after all these years Emagic (and now Apple) haven't provided a way to mute toggle the MIDI return for recording! Surely I'm not the only person who needs this?


Is there some Nahmani ninja secret I'm not aware of?


I am (still) using my trusty Unitor 8 Mk II, with the P155 using physical port 7 for both MIDI in and out.


Thanks David, and thanks again for your great Peachtree books!



Link to comment
Share on other sites

Look in either the project prefs or general prefs for a function that lets you set "device without MIDI thru" or something like that. Hopefully that one is still in LPX. Set it to the Yamaha and see if it works for you.


Otherwise --- and I'm quite serious about this --- take the easiest route there is: just pull the USB cable (or the MIDI in cable) from the Yamaha. Bingo.

Link to comment
Share on other sites

Instrument Without MIDI Thru Function


and it's in Project Settings > MIDI


I had previously explored that setting but the pulldown menu had HUNDREDS of GM Device options, dozens per GM Device 1, GM Device 2, GM Device 3 etc. In fact, it was so slow that I didn't bother scrolling down the menu for 5 minutes to where the MIDI track linked to the Unitor Port to my Audio MIDI Setup-defined and named P155B was indeed there in the list.


Thanks Ski!




screen shot of the bug, urm, feature.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...