Jump to content

Screen keeps on going back to beginning?


gno

Recommended Posts

This is an intermittent problem I'm having. It comes and goes and I don't know why. Let's say I'm at bar 1 and zoomed in to where I can only see bars 1 - 15. I want to go to bar 60 so I start horizontal scrolling with either the track pad or the magic mouse. The moment I lift my finger off the track pad or the mouse, the screen scrolls back to bar 1.

 

One way this behavior starts is during a recording session - For example if I am zoomed in at bar 60 and record a take, but I screwed up the take and hit cmd-z to undo - it will undo, but the screen scrolls over to bar 1 even though the playhead is at bar 60. If I press play the screen will go back to 60. My work around is to zoom all the way out so I can see the whole screen. However, sometimes I need to zoom in really close to set the punch in to the right spot.

 

Again - it is intermittent and comes and goes. But it seems to happen often enough - like a few times during a recording session or subsequent mixing afterwards.

 

Anyone else getting this?

Link to comment
Share on other sites

Logic's weird zoom behavior has always really annoyed me. Now that I 'm using a trackpad (can pinch zoom) I find it bothers me much less.

 

I don't think this will stop your issue because it sounds like it's jumping back to the wrong spot, but it could make zooming back out and in again much quicker and more comfortable.

 

I seem to remember having some kind of similar issue in the past and it was because it was jumping back to the beginning of a selected region. Perhaps when you undo the region that you just recorded it is autoselecting the previous region in the track and zooming to the beginning of that region.

 

Maybe if you do at least one take and leave it intact, to act as a guide for Logic, before using control Z to undo. Meaning don't undo the first take but do a new take afterwards. Now Logic will put the second recording as a 'take' so if you undo it, logic will by default zoom back to the beginning of the take folder instead of beginning of project.

Link to comment
Share on other sites

This is an intermittent problem I'm having. It comes and goes and I don't know why. Let's say I'm at bar 1 and zoomed in to where I can only see bars 1 - 15. I want to go to bar 60 so I start horizontal scrolling with either the track pad or the magic mouse. The moment I lift my finger off the track pad or the mouse, the screen scrolls back to bar 1.

 

One way this behavior starts is during a recording session - For example if I am zoomed in at bar 60 and record a take, but I screwed up the take and hit cmd-z to undo - it will undo, but the screen scrolls over to bar 1 even though the playhead is at bar 60. If I press play the screen will go back to 60. My work around is to zoom all the way out so I can see the whole screen. However, sometimes I need to zoom in really close to set the punch in to the right spot.

 

Again - it is intermittent and comes and goes. But it seems to happen often enough - like a few times during a recording session or subsequent mixing afterwards.

 

Anyone else getting this?

 

Have you taken a look at the Navigate/Play and Stop button options? Depending on what you have checked this may explain what's happening. You will need to have the Show Advanced Tools checked in the Logic Pro Preferences in order to see the Play and Stop button options.

Link to comment
Share on other sites

Logic's weird zoom behavior has always really annoyed me. Now that I 'm using a trackpad (can pinch zoom) I find it bothers me much less.

 

I don't think this will stop your issue because it sounds like it's jumping back to the wrong spot, but it could make zooming back out and in again much quicker and more comfortable.

 

I seem to remember having some kind of similar issue in the past and it was because it was jumping back to the beginning of a selected region. Perhaps when you undo the region that you just recorded it is autoselecting the previous region in the track and zooming to the beginning of that region.

 

Maybe if you do at least one take and leave it intact, to act as a guide for Logic, before using control Z to undo. Meaning don't undo the first take but do a new take afterwards. Now Logic will put the second recording as a 'take' so if you undo it, logic will by default zoom back to the beginning of the take folder instead of beginning of project.

 

You've hit on another thing that may be related. When I use cmd-Z to undo a take it seems to select all regions in the track. Sometimes it goes back to the beginning, sometimes not. I've actually done what you suggested - just leaving a crappy take instead of undoing it. I'd rather undo it because the crappy take takes up vertical real-estate. I think the cmd-z undo function in relation to recording takes is buggy.

Link to comment
Share on other sites

This is an intermittent problem I'm having. It comes and goes and I don't know why. Let's say I'm at bar 1 and zoomed in to where I can only see bars 1 - 15. I want to go to bar 60 so I start horizontal scrolling with either the track pad or the magic mouse. The moment I lift my finger off the track pad or the mouse, the screen scrolls back to bar 1.

 

One way this behavior starts is during a recording session - For example if I am zoomed in at bar 60 and record a take, but I screwed up the take and hit cmd-z to undo - it will undo, but the screen scrolls over to bar 1 even though the playhead is at bar 60. If I press play the screen will go back to 60. My work around is to zoom all the way out so I can see the whole screen. However, sometimes I need to zoom in really close to set the punch in to the right spot.

 

Again - it is intermittent and comes and goes. But it seems to happen often enough - like a few times during a recording session or subsequent mixing afterwards.

 

Anyone else getting this?

 

Have you taken a look at the Navigate/Play and Stop button options? Depending on what you have checked this may explain what's happening. You will need to have the Show Advanced Tools checked in the Logic Pro Preferences in order to see the Play and Stop button options.

 

My transport settings are below. But you hit on another thing - I have set my space bar to return to the last playhead position instead of acting like a pause button. This is one thing I really liked coming from Sonar, and it's nice I can do it in Logic, although it doesn't work 100% of the time. Maybe this non standard key command is goofing things up?

http://i687.photobucket.com/albums/vv239/guitartrek/ScreenShot2014-03-15at35351PM_zpse1bf3b59.png

Link to comment
Share on other sites

It's happening again. But I'm not recording at all - just editing. I'm zooming in and it wants to go back not to the beginning but a previous playhead position - like a few playhead positions ago. it's like it is confused at which playhead position to go to.
Link to comment
Share on other sites

It's happening again. But I'm not recording at all - just editing. I'm zooming in and it wants to go back not to the beginning but a previous playhead position - like a few playhead positions ago. it's like it is confused at which playhead position to go to.

 

Hi,

 

What are your settings underneath the Navigate/Play and Stop Button Options? They can be different. See screenshot...

play.jpg.3299d9ea541b3b0f43baaea7b74f0a81.jpg

stop.jpg.b986b21983085fb033827fdfc9dc3f52.jpg

 

Another thing to check are your catch settings. If you are editing in one of the editors these settings are good to know about also...

catch.jpg.9ff913fe496d33d4c440ca3a0bfded61.jpg

Link to comment
Share on other sites

foreststone: Thanks for your help

 

My settings are like yours with the following exceptions: I don't have "Play from selected region" selected, and I do have "Stop and go to last locate position" selected.

 

On the Catch menu I have "Catch when Logic starts", and "Catch when moving playhead" both selected. I'm not sure what this means.

Link to comment
Share on other sites

foreststone: Thanks for your help

 

My settings are like yours with the following exceptions: I don't have "Play from selected region" selected, and I do have "Stop and go to last locate position" selected.

 

On the Catch menu I have "Catch when Logic starts", and "Catch when moving playhead" both selected. I'm not sure what this means.

 

Try deselecting the "Stop and go to last locate position" and see if that helps. This sounds like the setting that is causing your view to jump back to previous locations. Try experimenting with these Navigation menu options to see what fits your workflow best.

 

The Catch setting applies to the editor window views such as the piano roll. The view will update(catch) to where the playhead is. I like having the "Catch when Logic starts" deselected because if I'm editing a midi region in the piano roll I don't want the view to keep jumping around to where the playhead is.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...