Jump to content

Logic X doesn't see BFD2 as a plug in [SOLVED]


Johnny Cakes

Recommended Posts

Hello Gentlepersons

 

I have just installed Mavericks and Logic X and when I launch old Logic 8 projects I am told that BFD2 is not available as a plug in. Yet it is installed in my applications folder. Is there a way of getting X to see it?

 

Model Name: iMac

Model Identifier: iMac11,3

Processor Name: Intel Core i7

Processor Speed: 2.93 GHz

Number of Processors: 1

Total Number of Cores: 4

L2 Cache (per Core): 256 KB

L3 Cache: 8 MB

Memory: 12 GB

 

Apogee Duet 2 - BFD 2

Link to comment
Share on other sites

  • 2 months later...

Hi guys,

 

I'm also having an issue with this. I just recently got a new iMac and upgraded to LPX from LP9. I have BFD2 installed but neither version of Logic will see it (I really only need it for LPX). It loads fine standalone. I'm not great with the nuts and bolts sort of stuff -- how do I make sure BFD2 is the 64 bit version?

 

Any help is greatly appreciated, thanks!

Link to comment
Share on other sites

Hi,

 

Go to Logic Pro X menu > Preferences > Audio Units Manager...it should be listed there as "successfully validated" for you to be able to use it in Logic. If you don't see it there, it could be you haven't installed the Audio Unit version of the plug-in (Logic doesn't use VST or any other plug-in format, only Audio Units).

 

J.

Link to comment
Share on other sites

Any ideas on how I would install the audio unit version of the plug-in?

 

Actually there's nothing for the user to do to choose what plug-in format to install. The installer installs all plug-in formats automatically. You should have a "BFD2.component" in Macintosh HD/Library/Audio/Plug-ins/Components/. If it's there, try restarting your computer. If Logic doesn't scan it and validate it after that, try deleting the Audio Units cache file to force revalidation of all Audio Units: the file is in Macintosh HD/Users/your username/Library*/Caches/AudioUnitCache/com.apple.audiounits.cache.

 

*The user Library folder is hidden by dealt in recent versions of OSX. If you don't see it, you can get to it quickly by entering the Finder's Go menu and pressing the Option key.

 

J.

Link to comment
Share on other sites

I did all those things however none of it worked until I restarted the computer -- then Logic rescanned for new Audio Units when opening, so I'm not entirely sure which of those suggestions was the deciding factor, unfortunately.

 

I guess I forgot to say that Logic needs to be closed while you install the plug-in...the scanning and validating process happens when Logic opens. Same thing applies if you delete the Audio Units cache.

 

Anyway, glad you got it working in the end! :)

 

J.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...