Jump to content

Song Length Bug

Ed Alton

Recommended Posts

Most of the music I do is short, so I usually set the “song length” to about 30 or 40 bars. When I save and reopen the same file the “song length” arbitrarily will change to some crazy large length, like 1,073 bars or 542 bars. The song length is never remembered or correct when reopening a file.


Any ideas?

Link to comment
Share on other sites

I can't confirm this behaviour.

Do you have any additional information about your project? Did you start with a new empty template?


Click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic 10.0.6)

• OS X version and sub-version (e.g. OS 10.9.2)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2.2 GHz Intel i7)

• Memory (e.g. 8GB)

• Audio interface manufacturer and model (e.g. RME Babyface)


(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

Link to comment
Share on other sites

For some stupid reason in LX, even when you select a region to cycle with the loop markers, the song marker no longer snaps to the end of the region as it used to in L9. So when you export within set region markers, if you haven't moved your end song marker to the end of the region, you end up exporting loads of fresh air up until the other marker. V annoying indeed.


The workaround is to use the ctrl-click menu/export audio option.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...