Jump to content

Roland A PRO not writing fader automation


Recommended Posts

I have a Roland A800 PRO and I have fader 2 setup to CC 7 so that it control the fader of the active track in Logic X. Everything works fine except automation. I am able to control the fader in Logic with the Roland fader but whether I select Latch, Touch or Write it doesn't write any automation. Can some please tell me how to set things up so I can use one of the faders on my controller to write automation on to the selected track in Logic X?
Link to comment
Share on other sites

Hi radicalgel.


Logic will respond to two different kinds of automation.

One is "track automation" and the second is "MIDI draw" (region based automation).


Touch/Latch (don't use Write) is for entering track automation.

This is what I suggest:

  • Change your fader 2 to something else than CC7 so that it won't collide with Volume on the Logic channel strip fader. This is not necessary but it may spare you some headaches later on.
  • Choose Mix > Enable Automation Quick Access.
  • Click Assign and slowly move the hardware fader up and down. Make sure that it’s moved through its entire range.
  • Click the Done button below the Off/On buttons in the Automation Quick Access section.

Now this fader will control the visible automation on the selected track.

Set your track to latch and automate away.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...