Jump to content

Latency offset problem (I/O plugin) [SOLVED]


Recommended Posts

It's really strange. Yesterday I made a few test page and the problem appears very random. Once opened, the project shows the correct value of ping +64 samples and re-opened changes the value to +7293 samples. In any case, the I / O plugin properly compensates for latency. I do not know quite what it is.


I suspect that this is a matter of Mytek's drivers...

Link to comment
Share on other sites

Where's your Recording Delay set at? Should be 0 samples.



The recording delay will not change the ping values.

It will only move the recorded audio with the amount of samples that you specify to compensate for the delay.


The OP has has a roundtrip latency of +64 samples at the sample rate he is using.

He should then set the Recording delay to -64 samples to get sample accurate recordings.

Link to comment
Share on other sites

The problem is that LPX and LP9 shows totally different ping / latency offset of the I/O plugin. Why?


That is pretty strange.

Have you tried trashing the LPX preferences?




Is this on the same project converted to X or are you measuring the round trip on new empty projects?

Which version of OS X do you use?


They are in the chain with firewire.


Ok, I see that the driver is from June 2013. Have you tried contacting Mytek?

Link to comment
Share on other sites

Hey, it was a wild guess.


Sorry if my reply was to harsh.

I just don't think that "Should be 0 Samples" is a good advice, specially not in this case where the OP has provided his roundtrip latency measurement.


I think we've seen enough cases with recording delay set to -5000 samples creating havoc.


We certainly have. I even had a local dealer call me asking why his recordings where misplaced.


Isn't Mytek one of the expensive brands?


Yes, I would not call them cheap. :)

Mytek Digital 8X192 ADDA - Vintage King Audio

Link to comment
Share on other sites

Thnx a lot for yout help. Looks like drivers messed up with roundtrip latency. I have installed drivers one more time and it looks like problem gone. Anyway the offset is bigger - not 85 samples but 96... 44.1 kHz.


All the best & happy eastern

Link to comment
Share on other sites

  • 1 month later...

Hello everyone,


I've lost my original Recording Delay Offset numbers for the Apogee Duet (iOS/Mac).

My i/o ping plugin shows a latency of -1 sample @ 44.1khz. In Logic X, does that mean my "Recording Delay" slider [General < Devices] should be set to -1 samples or +1 samples? My latency is a little different than in Logic 9.1.8.

Link to comment
Share on other sites

Update: Getting the system's "perceived" latency of -1 sample from the i/o ping plugin, I adjusted the "Recording Delay" slider to +1, and that seems to do the trick. I used the "Don't Stop Believin" loop test because it has real instruments and lots of different kinds of transients. It's not a complete null as I can make happen in Pro Tools LE 5.x-9.x, but it's extremely close. The buffer size seems not to matter, nor the plug in compensation: I punched in and out in different parts of the tune. The only thing that makes a difference is the Recording Delay slider. This may be a change in Logic X. Anyway, watch out for your preferences and offsets getting changed with software updates. Yikes.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...