Jump to content

Beat mapping audio screws up midi??? HELP!!


orangedog

Recommended Posts

Am I in the twilight zone or what?

I recorded a few midi tracks to later accompany an audio track then went back to beat map the audio to retain the flow of the original track which is rubato to say the least.

So I zoom out and listen and find my midi is completely screwed up.

This hasn't happened to me before so I am wondering 2 things

1. can I get my midi to snap back to the normal bar positions without doing it by hand?

2. I s there some sort of setting I have inadvertently clicked to make this happen so i never happens again?

Thanks fellow Logicians,

ODM

Link to comment
Share on other sites

Am I in the twilight zone or what?

I recorded a few midi tracks to later accompany an audio track then went back to beat map the audio to retain the flow of the original track which is rubato to say the least.

So I zoom out and listen and find my midi is completely screwed up.

This hasn't happened to me before so I am wondering 2 things

1. can I get my midi to snap back to the normal bar positions without doing it by hand?

2. I s there some sort of setting I have inadvertently clicked to make this happen so i never happens again?

Thanks fellow Logicians,

ODM

 

When beat mapping, I find it is a good idea to first SMPTE-lock all MIDI regions in the affected portion of the song. (Right click on each MIDI region and select SMPTE Lock -> Lock SMPTE Position.) After beat-mapping is completed, you can unlock the regions for normal editing again thereafter.

Link to comment
Share on other sites

Have you updated your Logic 9 to the latest available version (9.18)?

 

Beatmapping to a variable tempo audio track incorporates tempo changes in the project, consequently causing the pre-recorded MIDI data playback tempo to modulate accordingly, which will sound differently from what was originally recorded.

 

To snap the MIDI notes to their original positions, try the following steps:

  • -In order to save your beat mapping work, save your project as it is on a different name
    -Bounce and
Export the beat mapped audio track to an audio file that will contain the tempo changes
-Undo the beat mapping of the currently loaded project (delete the tempo changes in the tempo list).
The MIDI data (notes) should automatically set back to their original position.
-From here you have two options:
  • A) Select all the MIDI data and
SMPTE lock them in place and import back the previously saved audio file (importing its imbedded tempo information and applying it to your project)
 
Or
 
B) Re-import the previously saved audio file but without re-importing or applying the imbedded tempo information in the project.
The latter seems simple but could not work...

Link to comment
Share on other sites

Again thanks so much for your detailed replies.

Atlas, I tried your steps and after deleting the temp changes in the tempo list my mid didn't snap back like I anticipated. I tried then erasing the beat mapping track and that didnt work etc.

I wonder if you might know if anything else needs to be checked? Thanks Again!!

If not thats cool, like I said i appreciate the help.

Cheers,

PS yes i am running 9.1.8.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...