Jump to content

Logic Pro X sidechain works, but not accurate


StevenD

Recommended Posts

Hello :)

 

I just bought Logic Pro X and started a new project. I needed a sine bass, so I opened the EXS 24 Sampler. I created an empty region and clicked in some 4/4 notes.

 

After that I created a new software instrument and opened Klopfgeist. My idea was to use Klopfgeist to trigger the sidechain for the sine bass. I gave klopfgeist a bus 1 output, wich created a new bus channel. I gave this bus NO output, because I just wanted to hear the effect of the sidechain.

 

I made sure that Klopfgeist have the right length. Now I opened a logic compressor on the sine bass channel and selected bus 1 at the sidechain function. I dragged down the threshold to -28dB, ratio 2.1:1, attack 4.0ms and release 45.0ms. I also made sure that klopfgeist gave enough signal to trigger the compressor. After all these steps I pressed the play button, but something seemed wrong.

 

THE PROBLEM: is that when I hit the play button the sidechain reacts in a very weird way, wich i've never heard before. It does not sidechain, but it gives the sine bass an extra low punch. When I drag down the threshold the sine bass and this weird punch get even louder. I first thought this punch could be klopfgeist it self, but thats not true, because klopfgeist is much higher in tone.

 

I checked the signal that was running through the compressor, wich was at -8. I also tried to select another kind of compression, for example: studio FET, but still the same problem. I replaced klopfgeist with a FM synth, and changed some compressor settings, and again it didn't work. I restarted logic many times and even tried to change my buffer size and putted on low latency mode, because I thought it could maybe fix it ( haha desperate ), but after that I ran out of ideas and felt like sharing my problem :mrgreen:

Second Subground 17.zip

Edited by StevenD
Link to comment
Share on other sites

Does the compressor have its internal sidechain filter on? Its in the extended parameters if you click the little triangle at the bottom of the compressor. It could be from that or from some distortion that would occur from the compressor, of which both functions are in the extended parameters. If neither function is on, try driving the compressors input a bit less to reduce distortion.
Link to comment
Share on other sites

Hey Vascillate, thanks for your ideas about what might solve my problem. The sidechain mode was actually off, so I putted it on, but then I noticed it still didn't work.

 

Hey David. I uploaded the compressed logic file where I talked about in my earlier post.

Link to comment
Share on other sites

The side chain mode mentioned is actually not what you think it is (I was confused at first as well). It is a filter that takes the analysis signal and runs it through a filter, so this is good for if you want to make your compressor less responsive to lower or higher frequencies. I will check out your file and see what's going on.
Link to comment
Share on other sites

Oh yeah definitely what David said. Try to keep from clipping anywhere in your effects chain and especially your outputs (including channel strip outs). Its just good technique, plus clipping inside your effects chain can drive you crazy when effects start acting weird and you don't know why, and after hours of searching for the answer you realize that the track is clipping inside of itself.
Link to comment
Share on other sites

Hey David. Thanks for your advise. I made a new project and opened a random synth and again a klopfgeist, that would trigger the sidechain on the synth. I kept auto gain off and made sure nothing was clipping. The sidechain is working better, but still not accurate. There are still some small punches, wich are very annoying.

 

I uploaded 2 audiofiles with 2 screenshots. On the first audio file '' SD Synth 0.0ms '' you will hear sidechain compressor (on the synth) with 0.0ms attack. On the second audio file '' SD Synth 14.5ms '' you will here the sidechain compressor with 14.5ms attack. Both have those annoying punches and I still have no clue how to get rid off them. I also uploaded a new compressed logic file, so you could check it out if you want.

 

p.s. sorry for those huge screenshots, don't know how to make them smaller :?

Sidechain not accurate 1.zip

814990795_SDSynth0_0ms.thumb.png.edd0e3ab3029845cbc72d92f3de8f005.png

204754163_SDSynth14_5ms.thumb.png.5e23807a842147d7a3da810716f164e7.png

SD Synth 0.0ms.mp3.zip

SD Synth 14.5ms.mp3.zip

Link to comment
Share on other sites

Try with a different compresor and see if that still happens. Also try it with a Logic synth (sometimes 3rd party plugs make weird problems). If neither of those work, open a new project and try the same sidechain, as some projects can become corrupted.
Link to comment
Share on other sites

Hey Vascillate, do you mean another compressor or a compressor type like FET/VCA?

 

I made a new project, tried all the compressor types and made sure that all the effects/audio units were from logic itself. Still I noticed a very soft tick/punchy sound in the beginning of the sidechain. The compressort type '' platinum '' does work, but not accurate. The rest of the compressor types are not even giving a sidechain effect at all.

 

Could it have something to do with my logic settings? If not, then maybe it might be actually a bug?

Link to comment
Share on other sites

Hey David. Thanks for your advise. I made a new project and opened a random synth and again a klopfgeist, that would trigger the sidechain on the synth. I kept auto gain off and made sure nothing was clipping. The sidechain is working better, but still not accurate. There are still some small punches, wich are very annoying.

I'm not sure what you mean. I listened to your mp3s and everything sounds normal to me. I also downloaded your Logic project, replaced the synth with one of the Logic built-in synths and everything works as expected.

 

I'm not sure what you mean by "punches"? All I hear is the attacks of the notes when you play a new chord, and the places where the compressor opens and closes as triggered by the side chain.

Link to comment
Share on other sites

Hey Vascillate, do you mean another compressor or a compressor type like FET/VCA?

 

I made a new project, tried all the compressor types and made sure that all the effects/audio units were from logic itself. Still I noticed a very soft tick/punchy sound in the beginning of the sidechain. The compressort type '' platinum '' does work, but not accurate. The rest of the compressor types are not even giving a sidechain effect at all.

 

Could it have something to do with my logic settings? If not, then maybe it might be actually a bug?

 

I mean a 3rd party compressor.

 

Are you sure your tick sound is muted/shorted out?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...