Jump to content

Logic won't launch - new just out of the box - help anyone!?


Recommended Posts



Please forgive me if this is covered elsewhere in the forum. Was not able to find it.


I just purchased Logic 7.2 (Academic), opened the package and installed it on my G4 iBook 1.33, 1GB ram, OS X 10.4.9 Quicktime 7.1.6


After installation, I just have NOT been able to get Logic to launch. Tried with and without the Xkey plugged in. Could not get Waveburner to launch either. Icon just bounces once and then nothing happens. The computer doesn't lock up or anything, the programs just don't launch.


Tried updated to 7.2.1, same thing, then the 7.2.3 update, ....same thing. Oh yeah, tried turning the computer on and off too.


Is there something simple I'm overlooking. I really would appreciate anyone's help on this. I have never had a piece of Apple software just not launch on this computer before.


Thanks for your time.



Link to comment
Share on other sites

Yes I did that early on in the process.


I have no idea what to do.


System profiler is recognizing the Xskey ok. Ran the updater tool for that and it stated there was no updated needed for the key.


Any other ideas?


This is ruining what would have been a wonderful day for me,....opening up that new box of software, oh what a feelin!

Link to comment
Share on other sites

yikes ... sometimes another application can cause a conflict ... i would go to apple's page for Logic and do a search ... Otherwise, the best suggestion i acan offer is to call Apple support ... i've called them concerning Logic before and they are very nice and helpful ... by the time you hang up the phone with them, you will be up and running ... wish i could be more of a help
Link to comment
Share on other sites

Try turning off (moving) any VST Plug-ins you might have intalled. Sometimes AUVAL crashes when trying to validate them.


AUVal does not check the VST Plug-in folder, only the component folder for audio unit plug-ins.


Do you have other Apple Pro apps installed? Have you installed the latest Pro Application 4.0 update? If not, try it,




then repair permissions again, restart Logic. This article:




is worth bookmarking as it describes the Logic startup key modifiers. You should try the AU Safe mode, start without audio, and the start without template or autoload options, if you're still having problems.

Link to comment
Share on other sites

Thanks for the replies.


Tried all the modifier keys,.....still doesn't load.


About plugins.....I never even make it to the Logic splash screen, so I did remove VST's but still didn't work. I think the launch process is not even getting that far.


I was already current on the latest pro app update.


what else,...oh yes, and I do not have any other pro-apps installed. All my other music apps are working just fine (Reason, Live, DP 5).


This is the weirdest thing I've ever seen.


One other thing: I took a look in my preference folders, and noticed that I do not see anything with the work 'logic' in it, so I'm thinking it never launch enough even to create preference files. Is that a correct assumption?

Link to comment
Share on other sites

man, this safari 3 box shifting, spell-checking s#!+ is freaking me out...


erm.... yes, when I first got hold of logic, the same thing happened—it wouldn't launch. and so i did the most natural thing that occurred to me, I reinstalled my os without having backed anything up. It was late, I was tired.


anyhoo (damn spell-check!), it then worked fine, but then stopped working again after i reinstalled camelaudio's free camelcrusher plug-in. intrigued, i set about testing: installed, it didn't work, unintalled, it worked. further intrigued, i went ahead and cracked camelaudio's whole suite.


at first, they didn't work, and then they did, and for (i stress) no apparent reason. being a decent fellow though, i then went ahead and deleted them all (i hadn't paid for them, and besides they were a bit limited and my god does that chamaeleon thingy suck :shock: )


does that help at all?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...