Jump to content

Logic Pro X Drummer - multi MIDI out [SOLVED]


angelonyc

Recommended Posts

I've created a nice drum track using Logic's Drummer.. I have it set to Multi...

 

When I play the song,, The Drum track is still there with it's own unique 'drumming display..

 

I want to split the drums to individual tracks for drums, but leave in MIDI format.. So far all I've seen is ways to make multi track audio stems..

 

Can someone explain, or point me to a video to figure this out.. I found the 'split midi by note pitch command, but it was grayed out...

 

 

Thanx..

 

 

Mark Styles

Link to comment
Share on other sites

You need to convert the Drummer region into a regular midi region first.

 

Create a new instrument track (not a Drummer track) on which you load the same drum kit patch as your Drummer's.

 

Alt-Drag & drop (=copy) the region(s) on the Drummer track to this new track (it's always better to work with copies). Mute your original Drummer track and play the new track, simply to make sure there's no audible difference (there shouldn't be). You'll see that the newly copied regions on that Intsrument track appear as regular midi regions, with notes in them (not the "drumming" display you refer to, which only appears on all regions of Drummer track(s)). You can now deal with these as regular midi regions, including editing individual notes, demixing by note pitch, etc.

 

I hope this will help.

Link to comment
Share on other sites

  • 4 years later...

%5Bimg%5D[/img]Hello: I have been doing this technique starting with the "Drummer" tracks, and then copying them to a new track (with duplicate settings), muting the original tracks, then converting the new track to MIDI so I can manipulate the drums within the piano roll - and here's the problem:

 

For whatever reason, this is creating 2 layers of MIDI notes on the new track; I can actually click on one MIDI note, delete it, there remains the first MIDI note. I would care, except this is creating some odd phasing/artifacting which is unaccepable for a good recording. What am I doing wrong here?

832638620_ScreenShot2019-10-05at2_50_40PM.thumb.png.c5e7aeab27c3d8303f7f69856a0481bb.png

Link to comment
Share on other sites

I tried another techique that SEEMS to eliminate this issue, no clue why: I copied the first (drummer) track, and pasted the whole thing next to the same (#1) track; then I copied THAT copy into the duplicate track, converted it to MIDI and... I don't see to be hearing the same phasing weirdness as before. Weird huh?
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...