Jump to content

LPX & Addictive Drums 2 Multi Out Problem [SOLVED]


Recommended Posts

Hi all,


I have used many different multi-out instruments before with LPX so have a fairly good understanding of how this works, however, I'm having a problem with Addictive Drums 2. AD2 is v. easy to route out by just clicking the arrows at the bottom of each channel and configuring them each to 'separate out'. I have obviously configured AD2 as a multi-out instrument first and then added aux channels in LPX to mirror the number of separate outs in AD2. My only problem is that LPX only sees the AD2 outs as stereo groups per aux channel i.e. ADD 3-4, ADD 5-6, ADD 7-8, but the AD2 outs are all mono, so the problem I am seeing is that I get the kick and snare on one aux channel together i.e. kick on out 3 and snare on out 4. So the sounds are kick on the left channel and snare on the right channel of this one particular aux channel example.


I have watched some tutorials/read manuals but I can only find info on AD1/LP9. On the tutorials, when they go to route the AD2 outs, it shows up as ADD1, ADD2, ADD3 etc. on the inputs drop down on each aux channel, so these route the AD2 mono out without problems - and not the stereo 3-4, 5-6 etc. issue that I am seeing with LPX.


I have tried various different ways around this in AD2 and LPX but can't understand why I can't just simply route the AD2 individual channels to an individual LPX aux.


So to be clear, what I'm asking is how do I get LPX to see each AD2 mono out without the 3-4, 5-6 etc. grouping?


Hope the above is clear, thanks in advance for any help that can be given.





Link to comment
Share on other sites

I have no problems here,it says 10 mono and 4 stereo and i can route all mono´s to mono aux´s ...http://tinypic.com/view.php?pic=24c75tg&s=8#.VMvL2cbctKo


Actually I think I've just found my problem based on your response. When I select AD2 as an instrument it only gives me an option for:




'Multi-Output (9x Stereo)'


I have no option for 10 mono and 4 stereo, any ideas why? Should I re-install the software or is there a setting in AD2 that I'm missing?



Link to comment
Share on other sites

I have no option for 10 mono and 4 stereo, any ideas why? Should I re-install the software or is there a setting in AD2 that I'm missing?


I really dont know why you only have 9 mono´s ?


I don't have any mono's, just 9 stereos, hence the reason the kick and snare are getting split L&R on one aux track. Very strange. I tried the XLN support for no joy as yet.


The list of routing option is as follows:


ADD1-2 (But doesn't show as 1-2, just as the 'Addictive Drums')

ADD 3-4









So 9 stereo in total......

Link to comment
Share on other sites

Okay, here's another update.......I opened AD2 in Ableton 9 and although the routing is a little different, I had no issues with getting the AD2 mono outs to play nicely with the individual Ableton 9 tracks. Kick on one track and snare + others on separate tracks.


What the hell am I doing wrong in LPX? I thought I was reasonably clued up with LPX!!! :D

Link to comment
Share on other sites

Last update, I promise!


So I uninstalled AD2 again and re-installed it a few times to see if there was something different I was doing, but it all seemed to follow the same process.


Anyway, I just installed it for the 3rd time and then opened up LPX, I added a software instrument as normal, but this time I set up the track as 'No Output' (instead of output 1+2) before confirming the command. I then went to the mixer section (not the inspector) and opened up AD2 from the Instruments drop down from the top of the channel strip, then hey presto! the options had changed to :


- Stereo


- Multi-Output (4xStereo, 10xMono)


Not sure where the problem was, but I have tried to replicate it by opening up an instrument a few different ways now and it gives me the proper output option every time - WEIRD?!?


Hope this helps anyone with the same issues.


Cheers :)

Link to comment
Share on other sites

  • 2 weeks later...
Good you solved it,but that is strange....I have the Multi-Output (4xStereo, 10xMono) option with output set to 1+2 ?

Was it an old project you opened from before you upgraded ?


Sorry for the late reply. No it was a new project created in LPX 10.1. I tried to recreate the problem a few times but no joy. It's been working flawlessly since I got the outputs behaving normally. It's a nice plugin, I'm glad I got it to work in the end :)

Link to comment
Share on other sites

  • 1 year later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...