Jump to content

Auto Input Monitoring still broken in 10.1 or not?


stormy

Recommended Posts

First post! :)

 

A bit of background: I've setup my new project studio with Logic Pro X. I am a fairly experienced Pro Tools operator. I had used Logic 9 in the past, but briefly.

 

I was doing some overdubs and I couldn't get auto input monitoring to work. I had to resort to clicking the "I" button even for recording.

 

I've found some posts by David where he states there was a known bug with it, but they are about 1 year old. Does this bug still exist?

 

I've also found out about the new pref "Input monitoring only for focused track, and record-enabled tracks" which I should disable.

 

Problem recap:

I'm doing overdubs. I have a record-enabled track, and I'm adding "comp" tracks, rather than simply punching in (it seems to be Logic's default, and it's fine by me).

 

  • On playback, I want to hear the existing track. This works :)
  • On record, I want to hear the input when I punch in.

 

Auto input monitoring should take care of this. However, I had no input audio when recording unless I clicked the Input button. I have the impression that this problem was project-specific. I'm away from the studio now so I can't check.

 

Any ideas on what to look for? Or a confirmation of the bug? Maybe it was all that darned new preference?

Edited by stormy
Link to comment
Share on other sites

Thanks! Unchecking that preference solved it. I've been trying to understand what is it good for, but I couldn't figure it out :D

 

Just to confirm, and for future searches that bring this topic, once that pref is unchecked, auto input monitor works like this:

 

-Record enabled tracks let you hear the input when the transport is stopped.

-On play, you hear the track.

-On punch-in, you hear the input.

 

I sometimes would need record enabled tracks to not pass the input audio with the transport stopped, but I don't think that can be done unless I switch auto input off and deal with the input options manually.

Link to comment
Share on other sites

  • 1 year later...

I was having the same problem. What does the actual auto input monitoring button/option do then? Whether it is on or off i still get the same outcome.

 

It plays the existing track until the auto punch region then punches in the input signal until the auto punch comes out.

 

I thought that if auto input mon was off then i would just hear the input signal the entire time. This is not the case. Any help???

 

Also, the auto punch does not seem to work when the count in is enabled. You have to create your own pre roll or use the cycle.

Link to comment
Share on other sites

What does the actual auto input monitoring button/option do then? Whether it is on or off i still get the same outcome.

 

It plays the existing track until the auto punch region then punches in the input signal until the auto punch comes out.

 

I thought that if auto input mon was off then i would just hear the input signal the entire time. This is not the case.

 

Funny, last week I thought about this thread. I have the same problem. Auto Input Monitoring does nothing.

 

I had a session and I was unable to make it work. Here's the scenario:

 

-Player records a track and wants to redo it.

-Player wants to rehearse his fix, playing along to the rest of the tracks, hearing his instrument, and not his recorded track.

 

Well, it can't be done. I hear the recorded audio and the input audio at the same time.

Link to comment
Share on other sites

Are you recording or not?

If you just want to practise you can mute the region?

 

Thanks Eric. There are a lot of workarounds, for sure. I could simply add another track for monitoring and mute the existing track.

 

If I'm recording and punching in, I still have a problem because I want the musician to start playing before the punch. When he starts to play, he will hear both the input and the recorded track, flamming against each other. Far from ideal.

 

How do you deal with this scenario?

 

Also, at this point I'm very interested in finding out what's does Auto Input Monitoring actually do. For me, Logic behaves the same whether it's enabled or not.

Link to comment
Share on other sites

If I'm recording and punching in, I still have a problem because I want the musician to start playing before the punch. When he starts to play, he will hear both the input and the recorded track, flamming against each other. Far from ideal.

 

How do you deal with this scenario?

 

Mute the take you don't want to hear.

 

Also, at this point I'm very interested in finding out what's does Auto Input Monitoring actually do. For me, Logic behaves the same whether it's enabled or not.

 

AIM is kind of the opposite of what you want it to do.

It turns off the incoming signal when its playing back and only turns it on when the punch is active.

If AIM is off you will always hear the incoming signal.

Link to comment
Share on other sites

AIM is kind of the opposite of what you want it to do.

It turns off the incoming signal when its playing back and only turns it on when the punch is active.

If AIM is off you will always hear the incoming signal.

 

Ok, then that's the same as Pro Tools (if memory serves me well), and it's not working for me. I'm using software monitoring, so everything comes from Logic.

 

When I do a punch in, the input is never muted. I get both the input and the recorded track.

 

Now, for the other case (wanting the player to play along), the solution would be to turn input monitoring on (the "I" button) and have him play along to the rest of the tracks without hearing the recorded take. I'm not sure that one is working either but I will check.

 

To sum up, here's how I think it should work (and it doesn't for me):

 

-AIM on: you can do a punch in and only hear the input when Logic is recording. During play, the track is played. --> I always get both, track and input.

-INPUT on: only the input plays and not the track. --> got to test, not sure how it interacts with AIM and with Record armed tracks.

 

Thanks for the help, maybe I'll finally be able to figure out what I'm doing wrong!

Link to comment
Share on other sites

Hey guys, yes when AIM is on the "live" signal on comes on during the punch in and out markers to records, the returns to the underlying take. However, is AIM is off i should only hear the live signal but i hear the live signal AND the underlying track the entire time. Basically the take you are trying to replace is always playing - until the punch in point.
Link to comment
Share on other sites

  • 3 months later...

As a Pro Tools refugee I also wish Logic would have an option for a simple Input Monitor Button = Input Signal only mode.

 

For doing punchins i can see the "both signals" option as being useful but only if I can easily turn the playback one down so that most of what i hear is the input signal. If the PB and Input obeyed the two settings of the fader (I have playback and Record decoupled) then that would be great but present implementation has both the playback AND Input signals obeying the same fader. Not useful at all for me that way....

Link to comment
Share on other sites

  • 1 month later...

I'm going to bump this up again for answers, because I still can't get this to work - at all.

 

This is from Apple's Logic Pro X manual:

 

When it comes to judging punch-in and punch-out points during punch recording, you should turn on auto input monitoring (which it is, by default). This setting allows you to hear the input signal only during the actual recording; before and afterward you’ll hear the previously recorded audio on the track. If auto input monitoring is turned o , you will always hear the input signal.

 

So, with AIM enabled, and a record armed track, the input should only play during the actual punch-in.

 

However, no matter what setting I choose, I always hear everything: both the input and the recorded track, before, during, and after recording.

 

Any ideas? I think this is a bug that doesn't happen to everyone, but still gets a lot of people, judging from forum threads across the web.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...