Jump to content

Smart Control "Min-Max" Range Bug


dadunn1700

Recommended Posts

When i try to stack EQ automation on a Smart Control knob the min/max range is completely screwed up. Ironically enough if i invert the mapping it works fine....meaning the min/max ranges match whats actually happening on the EQ......but if it's not inverted it's completely out of whack.

 

I'd like to add that this only happens when using the "Learn" button to map the parameter.. But when using huge plugins, like Izotope Trash 2, it's required....otherwise I'd be searching for awhile for to find what i need to map.

 

Is this a known bug when using the "Learn" feature in the Smart Controls?

 

 

**I recorded the screen showing precisely what i'm talking about.

 

http://youtu.be/z_OCqv74Klg

Link to comment
Share on other sites

I have no solution (indeed looks like a bug, I will try to confirm it), but what happens if you set that band to 20k before learning it?

 

And also:

 

click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic 10.0.7)

• OS X version and sub-version (e.g. OS 10.9.5)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2.6 GHz Intel i5)

• Memory (e.g. 8 GB)

• Audio interface manufacturer and model (e.g. Presonus AudioBox USB)

* relevant external disks or secondairy internal disks

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

Please also list whatever you own of those:

• MIDI controller(s), (hardware) synths, soundmodules, other MIDI-using hardware, external processing equipment, etc.

Link to comment
Share on other sites

I have no solution (indeed looks like a bug, I will try to confirm it), but what happens if you set that band to 20k before learning it?

 

And also:

 

click this link to your signature and add your system information:

• Logic version and sub-version (e.g. Logic 10.0.7)

• OS X version and sub-version (e.g. OS 10.9.5)

• Computer (e.g. MacBook, Mac Pro, iMac)

• Processor (e.g. 2.6 GHz Intel i5)

• Memory (e.g. 8 GB)

• Audio interface manufacturer and model (e.g. Presonus AudioBox USB)

* relevant external disks or secondairy internal disks

(most of that information can be found by choosing Logic Pro X > About Logic Pro X, and  > About This Mac)

Please also list whatever you own of those:

• MIDI controller(s), (hardware) synths, soundmodules, other MIDI-using hardware, external processing equipment, etc.

 

Thanks for getting back so quick. I added the info. I haven't tried moving the EQ peak filters to 20K and then mapping them with the "Learn" button. Might be a decent bandaid fix until this can be worked out. Also at the time i was doing this (making the video) i was only using my Macbook. No audio interfaces, midi keyboards, or external hard drives were connected to my Macbook.

 

Hoping this issue is limited to the EQ

Link to comment
Share on other sites

This is a feature Intended to keep the relation between different filters instead of having them mapped to the exact same frequency.

Click on the Open scaling on button and then Reset the filter's scaling to fix this for your particular use case.

 

 

So basically when you use Smart Controls w/ multiple parameters mapped to 1 knob, and u want everything to have the same scaling, you have to go in and make it work? Smart controls automatically vary the scaling with multiple parameters on a single knob?

 

Also I I tried scrolling through the list and selecting a peak filter in the chain and it worked as expected for some reason.

 

I thought Logic automatically used the up- ramp scaling on new smart control parameters?

 

Before getting your message I remade a FM8 growl from Ableton in LPX using the smart controls. I used the learn feature. Lots of things were mapped to a single SC knob (FM8 routing amounts, Izotope Trash 2, etc). When I finished It didn't sound right at all. Then I went into the "scaling" settings and noticed a lot of the parameters weren't being automated despite what the min/max setting were bc the scaling was set to a horizontal line at 0. I had to go in and select the ramp on almost all of them.

 

(Wrote this on a tiny iPhone. Apologize for bouncing all over the place w/ my chain of thought )

Link to comment
Share on other sites

So basically when you use Smart Controls w/ multiple parameters mapped to 1 knob, and u want everything to have the same scaling, you have to go in and make it work? Smart controls automatically vary the scaling with multiple parameters on a single knob?

 

No. This is a feature for the EQ.

Here's a demonstration of filter coupling:

 

1050515621_EQFilterCoupling.gif.a0bcb86f0570f47a0d8d38a1715de7f1.gif

 

Also I I tried scrolling through the list and selecting a peak filter in the chain and it worked as expected for some reason.

 

Yes. That will work fine in your case but try it with my example and you see why scaling while using Learn is useful.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...