Jump to content

Record audio in lpx with plugins on [SOLVED]


DMC63

Recommended Posts

I'm recording audio from a synth into logic x.

 

I have inserted plugins onto the channel strip.

 

When I record the audio it bypasses the plugins. So, when I play the audio back

the audio has not been recorded with the plugin effects.

 

I know I can record the audio in and then bounce in place with the plugins on an I will

then have the processed audio with the effects.

 

But, I'm recording a sample pack for a friend and I don't want to record audio into lpx then bip and clean up afterwards.

 

Is there a way to record audio into lpx running through the plugins so they're recorded at the same time as the audio?

Link to comment
Share on other sites

What you describe is the normal behavior. The recorded audio is always dry, meaning the plug-ins on an audio channel strip shouldn't affect what is being recorded: they process the audio in real time upon monitoring (during recording) or upon playback.

 

To "print" the plug-in's processing to your recording, you have to create Input channel strips (for the inputs you are recording) and place your plug-ins there. For this, choose Window > Open MIDI Environment and choose New > Channel Strip > Input.

Link to comment
Share on other sites

Hi David.

 

Thanks for the quick reply. I've opened the environment and created a channel strip input.

 

The channel strip appears in the environment as input 1. I have inserted an echo on the strip.

 

How is this routed?

 

I've attached a screenshot.

 

My synth is going into audio 1 (input 5 from soundcard)

 

The UM-1 is sending mtc and midi to synth.

 

I'm recording on audio 1.741227970_ScreenShot2015-02-04at22_46_55.png.ef54cb8110587e942469a9918120d50f.png

Link to comment
Share on other sites

If your synth is going into input #5 on your audio interface then the plug-ins should be on Input 5.

 

1) On the input channel strip, click the Setting button at the top and choose Copy Channel Strip Setting.

2) Select the input channel strip in the environment and in the inspector, set the Channel parameter to Input > Input 5.

3) Click the Settings button and choose Paste Channel Strip Setting.

 

There should be nothing to route. The input channel strip processes all audio coming in from that input before it is recorded.

Link to comment
Share on other sites

Ok, Despite your clear instructions I'm confused.

 

I done 1)

How do I select both the input channel strip and the channel strip in the inspector? I click on the input channel strip and nothing happens, if I right click on the input channel strip its highlighted, is this how to select it?

 

in the inspector audio 1 channel strip is visible and its' input is set to input 5.

 

I clicked the settings at the top of input 1 in the environment and clicked copy channel strip settings. I then went to the inspector and clicked the settings tab and pasted the channel strip settings there. The inspector channel strip change to the same settings as the input 1 in the environment.

 

When I record on audio 1 the echo sounds but when I play back with echo bypassed the recording is dry. The echo hasn't been printed.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...