Jump to content

Issue in LPX 10.1 using MIDI > Steven Slate Drums


noisenet

Recommended Posts

I posted this issue in the Logic forum but I'm also posting here in the hopes someone might have an idea why this is happening. I'm certain the problem is not with SSD software because it only appeared with the 10.1 update to Logic Pro X.

 

It's kind of hard to effectively describe this issue so I will also include a couple audio clips below...

 

What's happening is this: in a project I created in late 2013 in an earlier version of Logic Pro X, when I open it in version 10.1, it is as if the velocities of some of the drum hits (MIDI notes) have been drastically increased. For example, in the original, correct, version, the 'rolls' drum hits are very subtle, they're more felt than actually heard. Playing the same project in Logic 10.1, those 'rolls' hits are much louder, ruining the whole feel of the piece.

 

In the next section of the song, the hi hats are kinda alternating velocities and hits. In the correct version, it's subtle, meant to feel like if a real drummer were playing. Playing it back in Logic 10.1, the difference in hits is much more pronounced, again ruining the piece.

 

I restored Logic version 10.0.7 (the two versions can co-exist) and opened the project in question and, as expected, the piece played back perfectly as it's supposed to. Reopened in version 10.1 and BOOM. Incorrect again.

 

I don't think this is any kind of settings glitch as both Logic versions (I assume) are sharing the same prefs file (all my recording settings, buffers, etc - all user settings show up as being the same in both versions)

 

I made clips from both Logic versions...

 

LPX 10.0.7 - Correct:

[soundcloud]https://soundcloud.com/senesmusic/drums-correct-lpx-1007[/soundcloud]

 

LPX 10.1 - Incorrect:

[soundcloud]https://soundcloud.com/senesmusic/drums-correct-lpx-1008[/soundcloud]

 

Does anyone have any ideas, something perhaps that's been changed in Logic that would cause this? I can use 10.0.7 to work with the songs in question if need be but I'd REALLY prefer to use 10.1 - I'm really fond of the new compressor interface and am really digging on some of the new features in 10.1

 

Thank you in advance for any help you might be able to provide me.

 

Edit: Slate Drums is also updated to the most recent version...

Link to comment
Share on other sites

Eric - Thank you for your help on this. I've made a project file with just the drum section that is referenced in the clips in the original post. In the original project the drums are all split out to individual mixer channels for mixing purposes. In the project file I've just made it's just the stereo drum feed from Slate. I created the file in 10.0.7, then loaded it into 10.1 and the problem is there plain as day.

 

I'm running Slate Drums 4, the latest update. I also have the Chris Lord Alge expansion pack and I believe at least one of the kit pieces in the kit on this track is from that pack.

 

I have not tried with other drum samplers as I only have the SSD sampler. I didn't try it with Drummer because, after beginning the track using Drummer, when I switched to Slate for mixing I made quite a few changes so the track would work with Slate. Drummer uses articulation ID's for Hi Hat state, Slate uses separate MIDI notes for same....

 

Anyhow, the project file is attached, I look forward to your findings....

LPX 10_1 Drum Issue Test.logicx.zip

Link to comment
Share on other sites

I don't have SSD4 here but as far as I can hear from your examples the mapping is off.

Have you used Map converter on the plug-in? Could it be a mapping that isn't loading correctly?

 

In your "erroneous" example I can hear snare rolls on the first 5 bars triggered by A0.

This is the default in SSD4 as far as I can perceive but maybe you have changed that in your "correct" example.

Link to comment
Share on other sites

I haven't changed any of the mappings, just left them as they are upon install. That said, upon reading your most recent comment I've stumbled upon another anomaly - looking at the mapping (screen shot of the Slate Mapping screen attached) A0 is, indeed, the snare roll; clicking on the A0 piano key in Piano Roll plays the snare roll sound, however, when clicking on any of MIDI events that are on A0, a hat sound plays, pretty sure it's the foot clamp sound. So in other words - the sound that is playing from the hits on that note aren't the sound that that MIDI note is assigned to.

 

Additionally, looking at the hits that are causing the errant open hats to sound (A#1) in the second half of the clip, if I click the piano key for that note I get a wide open hat. On the mapping screen it's listed as a hat with CC note On. Clicking on any of the events on that note, however, gives me more of a closed shank sound. BTW - it's not a velocity thing, raising the velocity doesn't make the hat sound more open.

 

So, it now appears that 10.1 is, actually, playing the sounds as they're assigned whereas prior versions of LPX were playing them incorrectly, more in line with the sounds that Drummer had on those notes This is getting really confusing LOL!!

 

When I originally put this song down using Drummer, then changed to MIDI (for editing) using a Logic kit, the events on A0 were supposed to be foot clamped hat. When I shifted to Slate, somehow events on that note retained this assignment, even though that MIDI note is supposed to be the snare rolls hit... How does this happen?

863781323_ScreenShot2015-02-08at6_00_34PM.thumb.png.71643a1e5c7466158be3d324ce957878.png

Link to comment
Share on other sites

What it looks like to me is that it WAS an issue with earlier versions of Logic. What I mean is the last issue I reported on happens with 10.0.7 but not in 10.1. The problems I was having, therefore, were because those drum parts were programmed in an earlier version of LPX, where some problem existed. When I program drums I do so by ear, just dragging notes to whatever MIDI note sounds right. Apparently incorrect notes were sounding in the older versions of LPX.

 

10.1, on the other hand, IS playing the sounds as they're mapped. So, these sounds playing back CORRECTLY sounds incorrect to me because the parts were programmed with the incorrect note soundings.

 

I made this little video using version 10.0.7 showing what I mean about the incorrect soundings and an inconsistency therein. In version 10.1 when I click the individual MIDI events, they trigger the correct sounds - as shown by hitting the note name piano key in the piano roll.

 

I tried posting using the YouTube tag in the editor but that didn't convert to a link, just showed the BBCode around the URL LOL! so here's the URL....

 

https://www.youtube.com/watch?v=LPJ-tRqqSV8

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...