A technical support community for Apple Logic Pro users.

 
uncleozzy
Topic Author
Posts: 53
Joined: Fri Sep 28, 2007 11:39 am

Unexplained software instrument track behavior

Tue Jul 28, 2015 5:29 am

Hi all,

I know I have a bad mod wheel on my MIDI controller--it sends random messages sometimes--but I've got some strange behavior that I'm not sure is explained by that. There are two problems, which may or may not be related:

1. Sometimes, EXS24 tracks switch to the next patch in the list (I had a tubular bells track yesterday that spontaneously switched to xylophone, for example). I can't seem to find any pattern for this, but I'm willing to experiment if anybody has any suggestions.

2. Sometimes, software instrument tracks become transposed up a semi-tone. The transpose settings on the track, on MIDI Thru, and on the region are unaffected. I can "fix" this by either removing and re-inserting the instrument or by duplicating the track. This has happened both with Logic's instruments and with third-party instruments (XLN Addictive Keys, Martinic Combo Model F). Again, I don't see any pattern of when this does or doesn't happen.

I'm sort of baffled, because as far as I know the only bad signals coming in are CC1, which shouldn't cause either of these problems. Any ideas would be greatly appreciated. I'm hoping there's just some stupid key command I'm hitting accidentally or some rogue CC that would explain this, because otherwise I'm stumped.

Thanks!
Logic Pro X 10.4.5
OS X 10.14.5
2018 Mac Mini i7, 16GB RAM
Focusrite Clarett 8pre
 
User avatar
Atlas007
Posts: 9498
Joined: Mon Dec 14, 2009 11:58 pm
Location: Montreal

Re: Unexplained software instrument track behavior

Tue Jul 28, 2015 3:33 pm

Does your controller needs a driver update?
LogicPro 10.6.1 ( & 9.1.8),MainStage3.5.1
MBPro 17", Core2Duo, 8G, OSX 10.12.6
MacPro, Xeon 6Cores, 64GB, OSX 10.15.7
ULN8, MOTU MIDI TP-AV, C4, MCU Pro, KorgNano, Novation SLMkII
AAS, NI, Celemony, Spectrasonics, Korg, etc...
PC, iPad3(V-Control & LogicRemote), AtariST(Notator SL), Several vintage gear
 
uncleozzy
Topic Author
Posts: 53
Joined: Fri Sep 28, 2007 11:39 am

Re: Unexplained software instrument track behavior

Tue Jul 28, 2015 5:24 pm

Nope, not as far as I know. I actually just installed the latest drivers ... unless that was the problem. Both the MIDI controller and FW interface are super old.
Logic Pro X 10.4.5
OS X 10.14.5
2018 Mac Mini i7, 16GB RAM
Focusrite Clarett 8pre
 
CCTMusic
Posts: 2432
Joined: Thu Mar 30, 2006 4:34 am

Re: Unexplained software instrument track behavior

Wed Jul 29, 2015 10:36 am

Hi

uncleozzy wrote:


1. Sometimes, EXS24 tracks switch to the next patch in the list (I had a tubular bells track yesterday that spontaneously switched to xylophone, for example). I can't seem to find any pattern for this, but I'm willing to experiment if anybody has any suggestions.

Thanks!



Perhaps you have the EXS24 preferences set to use MIDI CC to "Previous/Next Instrument"?

EXS Prefs.jpg
EXS Prefs.jpg (72.15 KiB) Viewed 324 times


Ref Q2 Perhaps your keyboard controller is sending out Pitch Bend messages randomly?


CCT
MacPro 2x2.9 Quad 28Gb OSX 10.14.x / LPX 10.5.1
MacBook Pro Quad 2.6 16Gb OSX.10.15.7 , LPX 10.6.1
 
uncleozzy
Topic Author
Posts: 53
Joined: Fri Sep 28, 2007 11:39 am

Re: Unexplained software instrument track behavior

Wed Jul 29, 2015 5:00 pm

Ah, good thought, but no, those options are set to the default (no control).

And, unfortunately, none of the instruments that have had the transpostion problem respond to pitch bend.

I'm really stumped on these. I wish I had some reliable way to reproduce them, but it really does seem sort of random.
Logic Pro X 10.4.5
OS X 10.14.5
2018 Mac Mini i7, 16GB RAM
Focusrite Clarett 8pre
 
xgman
Posts: 590
Joined: Thu Jul 21, 2011 11:09 am

Re: Unexplained software instrument track behavior

Thu Jul 30, 2015 1:34 pm

I've had similar issues caused by a bit of some sort of corruption by a pitch wheel event which somehow altered the track pitch after it should have gone back to neutral position. Check to see if you have any events by the wheel and try to eliminate that. It may not be related in your case, but I have seen this effect a couple times.
{2018 27" iMac-Pro-10 core-RadeonProVega56 8gb-64gb ram-2TB int ssd+<4tb Samsung850-860evo ssd's in TB3 Akitio Enclosure> UAD Apollo x6-tb3/Yamaha2050/Amphion/Bowers&Wilkins/Komplete S61Mk2} latest OSX, latest LPX