Jump to content

System clock wrong


Recommended Posts

If you see the date/time at the top right of your screen, click that and choose "Open Date & TIme...", if you don't, go to the apple menu, choose "System Preferences" and click the Date & Time icon.


If you're connected to the internet, check "Set date and time automatically", otherwise set the date and time manually.

Link to comment
Share on other sites

thanks for your speedy reply, should have mentioned but had gone down that path already. Seem to have it fixed now by unplugging the exkey then putting it into a different port then changing the port while the error message was up. Thinking its an xkey issue as logic never got passed that point, time and date settings were always correct. Bit strange this, used to this kind of thing on a pc and this is the first issue of this kind I have had on the mac but I guess it was bound to happen sooner or later, all running fine now though.


Thanks for your reply.

Link to comment
Share on other sites

  • 13 years later...

Hi Everyone!

Im having this problem "System Clock wrong! The system clock on your machine is wrong! Check the time, date, and time zone settings"

The machine: Imac Mac OS X Yosemite Version 10.10.5 + Logic Pro 7.2.3

I also get the error with a Powerbook with Mac OS X 10.6.8


Until now I tried of course checking the time, date and time zone settings. I also tried the XS KEY Updater v1.0 from https://support.apple.com/kb/DL452?locale=en_US

Apparently the key is alright! But I keep getting this error. I need to acces to this old machine to rescue a lot of material that was produced 20 years ago.


Thanks for your help!





Link to comment
Share on other sites

  • 4 weeks later...

I vaguely recall this would happen if you hadn't run Logic for a long time - ie the key thinks "Hmm, Logic hasn't been run for 19 years, that seems suspicious, or the clock is wrong".


I'd try a few futzing things - switch the computer off, plugin the key in, start the computer, shut down, run Logic etc, to see if the XSkey will update it's internal clock. You could also try experimenting with the time zone, in case you're in a country that didn't exist back when LP7 was current (j/k!).


Run Logic, unplug the key, hot plug it back etc. See if it will let you launch Logic again. You could also try setting the clock to roughly when you think you last used Logic too, as something else to try.


Note - my XSkey is still going strong and working fine, but I do run Logic 7 a few times a year on average...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...