Jump to content

Adjusting height of mixer elements?


infernouk
 Share

Recommended Posts

Hey guys

 

I havent used logic X in a long time and was wondering if you could help me with the mixer as i set up my template.

 

As seen below i have a lot of space for the mixer to be taller, yet it isnt used...is there a way to increase the space and size of the elements to fill it?

 

Many thanks!

 

http://i.imgur.com/7w9eNDHl.png

Mac Pro 3.2GHz 32GB RAM OS 10.8.4

Logic Pro X | Steinberg MR816 | Sonodyne SM100K

Link to comment
Share on other sites

No, you cannot change the size of the channel strip elements. You can however resize your Mixer window to eliminate that empty space at the top. You can also choose View > Configure Channel Strips to choose which elements to show or hide. Finally, note that the Audio FX, MIDI FX and Sends sections will expand as you insert more plug-ins (or busses).

My new Logic Pro Book is out!

Link to comment
Share on other sites

No, you cannot change the size of the channel strip elements. You can however resize your Mixer window to eliminate that empty space at the top. You can also choose View > Configure Channel Strips to choose which elements to show or hide. Finally, note that the Audio FX, MIDI FX and Sends sections will expand as you insert more plug-ins (or busses).

 

ok great thanks, just a shape the faders cant be made larger as im on 4K and they looks ridiculously tiny!

Mac Pro 3.2GHz 32GB RAM OS 10.8.4

Logic Pro X | Steinberg MR816 | Sonodyne SM100K

Link to comment
Share on other sites

This has been an annoyance of mine since the change in layout on LPX. I know it makes signal flow sense to have the channel strip setting and instrument at the top... but it makes those things disappear quickly as sends are inserted and/or FX inserted. I wish those were at the bottom so when in the basic "Main Window" the instrument and/or channel strip setting wouldn't disappear. To bad they can't be reordered somehow.

 

DanRad

Mac Pro 3.33 6 Core - MacOS 10.13.6 - Logic 10.3.3 - Taurus

Link to comment
Share on other sites

This has been an annoyance of mine since the change in layout on LPX. I know it makes signal flow sense to have the channel strip setting and instrument at the top... but it makes those things disappear quickly as sends are inserted and/or FX inserted. I wish those were at the bottom so when in the basic "Main Window" the instrument and/or channel strip setting wouldn't disappear. To bad they can't be reordered somehow.

There are many bugs in Logic's GUI. It's completely non-standard to display an element that is taller than the pane displaying it, and to not provide the ability to scroll up or down to see the different parts of said element.

My new Logic Pro Book is out!

Link to comment
Share on other sites

  • 1 year later...
  • 3 years later...

My problem is that this actually goes beyond just user interface for me. the faders are so short that the tiniest changes make big jumps in DBS .

it's sometimes hard to get the perfect level when you're dealing with small increments. Is there a way to adjust this?

ps I'm used to nice long faders in Pro Tools where this has never been a problem.

thanks

Link to comment
Share on other sites

You can help the "big jump" problem by changing the fader display scale to "Exponential" - Preferences>Display>Mixer - Level Meters: Scale

 

Changes the fader "throw" to -30 dB at the bottom, exponentially scaled to 0...much finer control.

 

I would be nice to actually have 100 mm fader throw, with exponential scale too ;-) !!

Logic Pro X 10.6.3, Logic Pro 10.7.0 - OS X 10.15.7, macOS 12.0.1 - iMac19,1 27" - 3.6 GHz Intel 8 Core i9 - 40GB memory - - MacBook Pro M1Pro 14" - 16GB memory - 10 core - 16 GPU - 1TB SSD) - Behringer XR18 - iPad Air (4th gen) - LaunchKey 37 mk3 - LaunchPad X - ioStation 24c - Logic Pro Command of the Day

Link to comment
Share on other sites

You can help the "big jump" problem by changing the fader display scale to "Exponential" - Preferences>Display>Mixer - Level Meters: Scale

 

Changes the fader "throw" to -30 dB at the bottom, exponentially scaled to 0...much finer control.

 

I would be nice to actually have 100 mm fader throw, with exponential scale too ;-) !!

 

 

Thanks, i'll check it out. u rock!

Link to comment
Share on other sites

  • 5 months later...
Interesting Topic, but either I am doing something wrong or it doesnt work like facej described. When you change it to exponential the metering changes, but the actual fader stays the same, you still have .5db steps around -30dB etc. (for me the resolution doesn't change AT ALL) Better fader resolution is really something that apple should improve about logic IMHO.
Link to comment
Share on other sites

The size of the fader does not change - only the scale - in db-Linear -60 to 0, exponential -30 to 0. When I use my trackpad to adjust the fader I see the increments at .1, no matter which version of the scale is by the meter. The steps on the scale are the levels, the fader adjusts from -infinity to +6 in .1 increments.

 

The visible scale values is not fader resolution, it's just an approximation. The numerical displays give more precise values.

Logic Pro X 10.6.3, Logic Pro 10.7.0 - OS X 10.15.7, macOS 12.0.1 - iMac19,1 27" - 3.6 GHz Intel 8 Core i9 - 40GB memory - - MacBook Pro M1Pro 14" - 16GB memory - 10 core - 16 GPU - 1TB SSD) - Behringer XR18 - iPad Air (4th gen) - LaunchKey 37 mk3 - LaunchPad X - ioStation 24c - Logic Pro Command of the Day

Link to comment
Share on other sites

When I use my trackpad to adjust the fader I see the increments at .1, (...) the fader adjusts from -infinity to +6 in .1 increments.

When I use my trackpad to adjust the fader, the increments go: -∞ , -95.0 , - 90.0 , -85.0 , -80.0 , -75.0 , -70.0 , -65.0 , -60.0 , -58.0 , -56.0 , -54.0 .... etc. and the resolution gets finer as I approach 0.

My new Logic Pro Book is out!

Link to comment
Share on other sites

hmmm - db-Linear? I just watched the little display above the fader as I moved it and got the .1 increments, but I work in Exponential mode - anything below -30 dB is dead to me ;-) got me some gates ;-)

Logic Pro X 10.6.3, Logic Pro 10.7.0 - OS X 10.15.7, macOS 12.0.1 - iMac19,1 27" - 3.6 GHz Intel 8 Core i9 - 40GB memory - - MacBook Pro M1Pro 14" - 16GB memory - 10 core - 16 GPU - 1TB SSD) - Behringer XR18 - iPad Air (4th gen) - LaunchKey 37 mk3 - LaunchPad X - ioStation 24c - Logic Pro Command of the Day

Link to comment
Share on other sites

hmmm - db-Linear?

The Level Meter scale preference (Sectional dB-linear or Exponential) is a Display preference: it affects only the meter and its scale, but not the fader resolution behavior.

 

I just watched the little display above the fader as I moved it and got the .1 increments, but I work in Exponential mode - anything below -30 dB is dead to me ;-) got me some gates ;-)

You get .1 increments only up until -6 dB then .2 increments until -18 then .5 increments, etc...

My new Logic Pro Book is out!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...