Jump to content

Trying to record audio and software instruments at the same time?


Recommended Posts

Hi there,


I am trying to record audio from my Roland Gaia SH-01 and two software instruments, one software drum kit using my Akai and the other software (strings or synth sounds) on my Axiom Pro.


I am almost able to do this, where I can record both software instruments on their respective tracks on their respective devices at the same time, which is what i want, however the audio from my synth will not record, even though it is monitoring and i can hear it. 


Vice versa, when I click all the R's to be record enabled, they are all red, however the audio track is flashing the red R at me. When I record with the audio track flashing, it will only record the audio and not the software instruments together. 


It seems right now i am forced to choose to record the software pieces together without the audio, or record the audio without the software instruments recording at the same time.


I am able to hear all the instruments together on their respective devices, which is awesome, I'm so close! Just when recording happens is when i am running into these issues. I try highlighting them all by shift clicking each track so they are all "selected", however whatever track that was selected/clicked primarily will record just that. For instance, I will click my software instruments and highlight the audio, and only the software will record. Will click/select the audio track first then highlight the software instruments, will only record the audio even though all the R's are red with the exception of the audio track flashing the red R instead of a stable red. 


I spent hours trying to learn about MIDI environment and really learned quick about all the different things you can do to your devices. Really amazing. I am so close though, i can taste it! Almost there. 

Link to comment
Share on other sites

Hi guys,


Thank you for the replies. I am still unable to do it. I can almost get it, but what is happening is that my SH-01 is also playing both its audio (which is what i want) however it is inputting midi data for the software instrument as well. How can i have the SH-01 output solely audio from the synth and not have it start writing notes that are going into the other instrument? Can't even begin with the Akai as it's doing the same thing. I cannot play all three together with the tracks to their respective devices. I dont want them interfering with one another, and no matter what i do, they are interfering with one another. 


I have attached a screenshot for a basic, new project. The classical electric piano is to play the Axiom solely, the Audio 1 is the SH-01 and the Gritty Funk GB is supposed to go to my Akai. 


The next screenshot is showing data written by my Axiom for the classical piano. However, if you notice in the green bar, you will see lower octave notes playing, which is from my SH-01. I dont want that. Those lower notes are supposed to be playing solely on the audio track and not getting recorded into the software instruments.. Even with the record enable and unchecking the input monitoring, the issue still persists. For some reason as well, I cannot have all three record-enabled. The audio tracks R flashes red for some reason, and when i click the next track, the R goes away on the previous one selected. 



Link to comment
Share on other sites

UPDATE: Okay, wow, I got this working. Thank you again for your help. One more thing though:


Only problem now, is that i cant hear the drums while recording, but they will still be written down and can hear through playback. Any way around that? Also, the screenshot i attached is the way its working for me. Kinda buggy though, the Axiom data inputs are showing up in the drum kit area, but after hitting stop everything recorded goes into its rightful place. 


Edit: I am back from another session of playing around, but now my synth is also playing notes meant for the Akai. I thought it couldn't hear it since I was playing a deep bass sound on my synth hitting a lower octave C note, and every time i hit it, it was also playing the bass kick on the software drums. Can't have that happen. Still trying with different things, but damn, this is super buggy. 


Link to comment
Share on other sites

Logic is a pain when you're trying to do things live with multiple midi devices.  One of my biggest wishes is for midi input devices to be selectable on individual midi tracks - pretty much like every other DAW out there.


You can hardwire midi devices to instruments via the environment, or use transformers to route specific devices how you like, but the environment isn't a great place to be going, particularly f you're on a high res screen as the interface is tiny, and has aged terribly.


What you need to do is set your midi devices on different channels and ensure that 'Auto Demix by channel' is set in the recording area of your project settings, and the correct channels are selected for each track (Using the inspectors on the left).


As you mentioned previously, the demix setting is what makes the recorded midi data split into the correct channels AFTER you've recorded.  As it's in the project settings, you may need to set this up in your default template for future projects if it's currently disabled.


What really winds me up with all this, is that External drum machines, usually, if they send midi data out when playing, have to be disabled via the environment to prevent spilling into the sequencer across any record enabled midi/instrument track.

Link to comment
Share on other sites

  • 2 years later...

Has this been improved at all in LPX 10.4

I want to record tracks simultaneously from an iPad running Logic Remote and a Roland MIDI Keyboard

I understand skulljumptoes' post and have found similar explanations on YouTube

Any advice welcome

Link to comment
Share on other sites

The only improvements i know of is that you can disable MIDI devices in Logic now... which helps if you've got external gear that's sending out MIDI data that you don't want to. But in regards to the general setup of multi MIDI Ins routing to different AU's then it's the same it's always been really.


I've been using Cubase for 9 months and it's so much easier to manage things like this that Logic just makes me angry with how it's not progressed in this area.


That said, for single controllers, one track at a time Logic is much easier so i can see why they focus on that feature.

Link to comment
Share on other sites

Thanks for the update skijumptoes. Disappointing for users like me who are in a band and want to use Logic to record jam sessions. I would have thought there must be a huge number of users who want and need this to be as simple as possible.
Link to comment
Share on other sites

I have just found that this is actually very simple now in Logic Pro X 10.4

As skijumptoes said.

No need to open the MIDI Environment. Just do the following:


1. Select File > project settings > recording

Tick ‘Auto demix by Channel if multitrack recording’


2. In the inspector strip at the left side

select ‘Track’

Change ‘MIDI Channel: All’

to ‘MIDI Channel: #’

where # is a number for the recording channel

matching the instrument number


3. Enable Recording on all tracks

Link to comment
Share on other sites

It's been like that for a while, but the problem comes when you navigate the project and you forget to leave the MIDI tracks enabled so that the Demix works - but you get used to checking everything before you record... generally. :)


But i always get instances in Logic where it doesn't record properly or live enables the track even though it's enabled, it's always be a pain to use consistently for me.


My problem further is having external hardware that sends MIDI data alongside Logic which i don't want to capture until i'm ready to commit - as this will flood any single record enabled MIDI track that i have (no matter what the demix mode is set to), so i use the Environment to cut it in and out as needed. Often jam with a mate who'e on V drums too so we're hearing the sound from that, but again it's sending MIDI data out, so i have to make sure that's either cut out or a dummy track created for it.


And to make matters worse i have a Yamaha MODX which, depending on preset can send on anywhere between 1 to 8,9,10 channels for a single sound (It generates arps on each channel too), and i also like to use that as a multi-arp for Virtual Instruments...


So i just use Cubase now as i can set up 16 channels purely for that device etc. So much easier to manage than having to fiddle around with Channel ranges and environment setups. It flabberghasts me how they haven't just added a device/port selection per track which defaults to 'any'.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...