Jump to content

Score has missing/blank area of page


Recommended Posts

Hello forum, I'm new to this neighborhood and this is my first post. I did some keyword searches here to make sure this issue hasn't already been discussed, but I didn't find anything so I figured I'd go ahead and start a conversation. Sorry if it's a little long-winded, but it's been a bit of a frustrating issue to deal with.


I regularly use the Score feature of Logic at my job. I recently upgraded from Logic Pro 9 to Logic Pro X, and although the interface and appearance took a little getting used to, everything has seemed to work fine.


However, I was editing the Score window (in full-page view) of a particularly lengthy session today when I came across one page that was almost completely blank. I don't just mean that the notes weren't there. The first staff at the top of the page was visible, but then the rest of that page was completely devoid of anything -- no notes, no measure numbers, no staves. The playhead would scroll over the blank area, and all the notes played perfectly fine, but I was unable to view or highlight anything at all in the blank area.


I tried switching viewing styles from "treble" to "piano." I got the same blank area, just a few pages later. I tried selecting a different MIDI track in Score mode, and I got the same blank area in the same place. Naturally, I tried the other de facto quick fixes: I closed and then re-loaded the session. I quit and then re-launched Logic. I rebooted the computer. No change.


I tried some other methods: I created a new session, and imported the original track into that new session...still got the blank area. I exported the region as a MIDI file, and manually dragged it into the new session...same blank area.


I should note that I have created some successful score sheets in Logic Pro X since I upgraded, but they've all been pretty short, limited to one or two pages. In this case, the blank area didn't appear until page 7 of the score. I tried loading a different session from about a week ago, and checked one of the MIDI tracks in Score mode there. It looked fine, but it was only 16 measures or so. I extended the MIDI region to about 100 measures, and pulled it up in Score mode, and right at page 7, the blank area struck again.


During one test of my original session, I saved my score as a PDF, and opened the PDF to view it. There were no blank areas at all, it looked perfectly fine. However, I obviously still need to see what I'm doing on screen with edits and annotations before I can save a finished PDF.


The only way I've managed to get this to work? I launched my old copy of Logic Pro 9, started a new session, and imported the track in question into the Logic 9 session. Pulled up the track in Score mode, and.....no problems. No blank areas.


So my question is: Has anyone encountered this problem using Logic Pro X? If so, is there a preference setting of some sort that I need to change, or is this an actual bug in the system? I would appreciate any tips anyone might have! Listing some of my system specs below in case that helps narrow things down.


Many thanks,

Dax B.


MacBook Pro (Retina, 15-inch, Mid 2015)

Processor 2.8 GHz Intel Core i7

Memory 16 GB 1600 MHz DDR3

MacOS Sierra 10.12.6

Logic Pro X Version 10.3.2

Link to comment
Share on other sites

Very strange.

I can not replicate the issue on my end.

Could it be a retina graphic card issue?

Try this:


  1. Quit Logic Pro X.
  2. Open the Applications folder and locate Logic Pro X.
  3. Highlight the app and press Command-I on your keyboard.
  4. Chose Open in Low resolution mode.
  5. Close the info pane and relaunch Logic Pro X.


Will that make a difference?

Link to comment
Share on other sites

Unbelievable -- that actually did solve the issue. The score doesn't look quite as sharp as usual, but at least I can see everything I need to work with. I would not have thought this weird recurring problem could have been caused by a graphics resolution issue, but there it is.


Thank you very much for the help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...