Jump to content

10.3.2: Musical grid display bug


Simon R.

Recommended Posts

I brought this up when 10.3.2 was released. Now it seems I have found out when it happens, and would be great to get it confirmed by someone closer to the development team than me...:)

 

MIDI recordings appear early in the grid in the piano roll by 1 beat.

Whatever I record is actually placed at the right spot, musically. But in the piano window it looks delayed, as if the piano roll view is offset in some way.

 

It seems to happen everytime you work in something non-4/4 - I have it happening hear in both 3/4 and 5/4. It seems Logic gets "confused" and thinks the first pre-roll bar (bar 0) is always in 4/4, no matter what signature you set, and then it screws up placement of content in the piano roll.

 

You can fix this after recording by recalling your screenset/reopening the piano roll - now all is fine again.

 

Look at these screenshots:

 

 

http://www.simonravn.com/media/screen1.png

 

You can see in the next one that somehow this also affects the grid in the MIDI draw part of the piano roll:

 

http://www.simonravn.com/media/screen2.png

Link to comment
Share on other sites

Hi David.

 

You are right, it isn't THAT easy to reproduce. But I found the reason. It seems it only happens when your project start points ends up not being on the first beat of a bar, e.g. 0 2 1 1 in stead of 0 1 1 1.

 

Usually I will want one bar of preroll to the project, so I move the project start pointer to "0".

 

Try this:

 

1) Open new, empty project.

2) Add any software instrument.

3) Drag your timeline start point arrow so it expands your view to include bare zero - so it says 0 1 1 1

4) Open a piano roll window or consolidated piano roll.

5) Not sure if this is necessary but I think it might be: Open recording setting dialog and change "Count in" to "none".

6) Open a time signature list. Change signature to 5/4

7) Press record, record something.

 

Everything recorded will now appear one bar early in the display of the piano roll. The project start point arrow will now show 0 2 1 1 1. If you move it to 0 1 1 1 1 it resolves the issue.

Link to comment
Share on other sites

Isn't Logic having issues with projects starting at 0? 

It's way easier to start your song start later, e.g. bar 2. My song arrangements start at bar 49 (I have a special reason and worklow, why I do this), and I set the project SMPTE sync settings, so that at bar 49 the time reads 1:00:00:00.00

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...