Jump to content

Need an older version of logic Pro for High Sierra


Chris Booth
 Share

Recommended Posts

Need help! Recently upgraded to High Sierra from lion OS (late 2011) Mac and was using logic pro 9. Logic pro 9 no longer works and can't seem to find an older version of logic, there are sites I tried downloading but that also won't install. Does anyone know where I can get or buy a version that will work on my Mac?
Link to comment
Share on other sites

As has often been repeated here, you buy a Logic Pro X licence from the App Store on a Mac running 10.4 or later. Then you go back to your HS machine, and download your purchased Logic from the AppStore - the App Store will give you the last compatible version of Logic for your system.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...