Jump to content

Arturia and Logic Pro: Analog Lab V not playing nice with Keylab 61 Essential


Recommended Posts

Hi -

This one is a bit complicated to explain, but I'll try.

I have Arturia's V Collection and also the Keylab 61 Essential.

It's very intuitive and a lot of fun to control the Arturia plugs with the Keylab Essential, and especially the meta-plugin, the Analog Lab.

Everything was working perfect for me with Analog Lab 4, but recently, after Arturia released the new version of the V Collection, with Analog Lab V (5) included, I started experiencing problems.


Before explaining things further, it should be noted that when launching Analog Lab V as a standalone, or either as an AU or a VST inside Ableton Live, everything still works fine.


In Logic however, some of the knobs stopped controlling the corresponding knobs on screen.

I contacted Arturia's support, and they kindly guided me through resetting the definitions on the Kelyab and on the plugins.

At the end of the process, i.e following Arturia's suggestions, I still get one knob not working properly.


I tried disconnecting the interface on Logic's environment, and connecting it to a midi monitor, to see what happens. The weird thing is that the "rogue" knob still acts weird (affecting another unrelated knob on the software) while all the other knobs and faders stopped working, as exoected when disconnecting the midi interface on the software level.


I've made a screen capture of this behaviour to try and demonstrate what I'm talking about.


Here: https://www.dropbox.com/s/c6m2rz0yetsy1p6/Arturia%20Lab%20V%20in%20Logic.m4v?dl=0


Does anyone have a clue what's going on?

Link to comment
Share on other sites

  • 1 year later...

Hi,sorry to resurrect an old subject but I have the same /similar issue with my Keylab Essential 49 keyboard.

Could you guide me thru the process of how you fixed this? I also have contacted Arturia CSupport. Still waiting


my post from the Arturia forum

"Installed everything.


Opened Keylab IV or V and whichever instrument I use the 1st encoders (slider and rotary from the left) do not control/work the parameters they should be assigned to. The rest of them work fine.

Also the mod wheel is not working. When you do it with a mouse in KL yes but physically from the keyboard no.


When I use Logic's midi learn function ....it works but it's visually kinda glitchy. Butin KL mode I am not supposed to use Logixc X midi learn.


Earlier today,when I just installed it - I was browsing thru KL:IV-V and it was working.

Standalone everything works fine. I tried reseting the Mackie control in the Logic X Control setup and now the faders in DAW mode do not work.

What should I do? "

Link to comment
Share on other sites

I also just checked the Library/Preferences and there is no such file as com.apple.logic.pro.cs


It sounds like you're looking in /Library/Preferences/, which is the wrong place.


You want ~/Library/Preferences/

(that's the preferences folder in your home Library, not the root Library).


The full path is /Users/*YOU*/Library/Preferences/ for the Logic preference files (substituting your account name for *YOU*), if you want to delete them.

Link to comment
Share on other sites

If you have customised those preferences, or broken them or stopped them from working, resetting them will get back to a known empty clean slate for you to (re)install your hardware.


I have no specific knowledge on that controller, or how Arturia have implemented plugin control, I was merely responding to you trying to find the preference file and looking in the wrong place and saying there isn't one.

Link to comment
Share on other sites

You should be alright, no need to worry.

Just in case, you can backup the file you are deleting (drag it to the desktop, and change its name by adding "backup" or something).

The only thing you might lose are some custom definitions you have made in Logic's behavior, and deleting this will reset it to it's factory settings.

Link to comment
Share on other sites

Yes you do - it is there, but the user Library folder is hidden by default.

In the finder, do Go -> Go to folder... and type in ~/Library/Preferences


Note: Spotlight searches do not search system locations by default, unless you explicitly tell it to.


Trust me, that folder, and those preferences are there. ;)

Link to comment
Share on other sites

So I got the answer from Arturia

Here's what they propose


"On the other hand, regarding your controller:


I- The following steps will explain how to delete the Logic Pro X user preferences, in order to potentially fix the issue your are actually facing:


1- Quit Logic Pro X if it is running.


2- In the Finder, choose "Go to Folder" from the Go menu.


3- Type ~/Library/Preferences in the field and click Go.


4- Remove the following files from the Preferences folder:






- Note that if you've programmed any custom key commands, this will reset them to the defaults. You might want to export your custom key commands before performing this step. Learn how to Browse, import, and save key commands.


5- If you upgraded from an earlier version of Logic Pro, also remove the "com.apple.logic.pro" file.


6- Then restart the computer."


Hope it helps

Edited by bebenavole
Link to comment
Share on other sites

Nah. Just wanted to put it here for future searches. I also only have 3 Logic related files of which one is different then what they have mentioned.

...logic10plistQ0Y7saC (safe to delete or no?)

I also do not have a file named com.apple.logic.pro

My version is 10.5.1, so maybe that's why



Link to comment
Share on other sites


The plot thickens

So I remove the two files from the folder. Restart the machine and open Logic.

Logic offers to download new sound and samples. Ok. Weird!??!


Now the Analog lab is working. Well Pigments still has no mod wheel connection

But in the DAW mode I have no control over the mixer faders and pans whatsoever


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...