Jump to content

Logic not recognising MIDI keyboard.


BeliefHaver
 Share

Go to solution Solved by enossified,

Recommended Posts

I have a Komplete Kontrol M32 and a new MacBook Air M1 with Logic 10.6.1 running Big Sur 11.1.

 

When I plug the keyboard in I get a message "Changed number of MIDI inputs/outputs". Logic does not ask to connect the keyboard. (The same thing happens in Garageband).

 

In Logic Pro > Preferences > Control Surfaces there are no MIDI Controllers listed.

 

However, in Audio Midi Setup > Midi Studio my keyboard is listed correctly and it is active.

 

I can use the keyboard as a standard midi device and some of the buttons work if I'm using a Native Instrument VST but the transport controls do not work in Logic.

 

Is this a problem of communication between Logic and the MIDI server?

 

Thanks in advance for anyone's assistance.

372518326_ScreenShot2021-01-24at8_45_03am.thumb.png.b124c2191b8d8d1236b21e17d182d019.png

Macbook Air M1 - macOS Big Sur 11.1 - Logic Pro 10.6.1 - Komplete Kontrol M32

Link to comment
Share on other sites

  • Solution

The M32 is not on NI's current list of products compatible with Big Sur. None of the Komplete keyboards are.

 

M1 silicon is still officially unsupported as of Jan. 12, 2021

 

Have you installed Komplete Kontrol, launched it standalone and performed the setup routine? If so, does the M32 work properly with the app?

 

On Logic's Control Surface Setup page selecting New -> Scan all models, nothing is shown?

Edited by enossified

Logic 10.4.8 - iMac12,2 - Intel Core i5 2.7 GHz 4 cores - 16 GB RAM - OS X 10.13.6

Link to comment
Share on other sites

Thanks for the idea David but I tried that and strangely it doesn't work. "No message received yet". I say it's strange because the transport controls work in Ableton so the hardware is ok. I think it might be a NI compatibility issue as the previous poster mentioned.

Macbook Air M1 - macOS Big Sur 11.1 - Logic Pro 10.6.1 - Komplete Kontrol M32

Link to comment
Share on other sites

Have you installed Komplete Kontrol, launched it standalone and performed the setup routine? If so, does the M32 work properly with the app?

 

On Logic's Control Surface Setup page selecting New -> Scan all models, nothing is shown?

 

Yes, I've installed Komplete Kontrol and it works in the app. I can also use Komplete Kontrol instruments inside Logic with the keyboard.

 

When I go New > Scan All Models the only Native Instruments controller to show up is the Komplete Kontrol S61. I've also tried deleting the Logic files in Library > Preferences.

 

The transport controls work in Ableton too. Perhaps you're right about NI needing to fix it, although I have heard that it works for some people in Big Sur with an M1.

Macbook Air M1 - macOS Big Sur 11.1 - Logic Pro 10.6.1 - Komplete Kontrol M32

Link to comment
Share on other sites

Maybe the keyboard has to be in some kind of "MIDI" mode rather than a specific control surface mode. The button, when pressed, should send some kind of MIDI data. You can monitor that with Logic's MIDI in monitor in the custom LCD display, or a 3rd party utility such as Snoize's MIDI Monitor (free).

 

I set the LCD mode to custom and it's only getting input when I use the keys or the two touch strips. The keyboard is in MIDI mode. There's a tiny monochrome screen on it and it never says "Komplete Kontrol" when it's plugged into Logic, as it does when you use the Komplete Kontrol app.

Macbook Air M1 - macOS Big Sur 11.1 - Logic Pro 10.6.1 - Komplete Kontrol M32

Link to comment
Share on other sites

Native instruments has a running process that installs the Komplete instruments into Logic when you run Logic and the keyboard is connected. It sounds like that's not working, likely because of the OS compatibility issue.

 

The NIHardwareAgent and the other one? Hmm yeah I guess if they aren't working there's not much chance of a workaround. Thanks.

Macbook Air M1 - macOS Big Sur 11.1 - Logic Pro 10.6.1 - Komplete Kontrol M32

Link to comment
Share on other sites

  • 2 months later...

Make sure you're running Logic in Rosetta mode. At least that's what I had to do to get Logic to recognize my S88 keyboard.

 

When I change Logic back to native mode, my keyboard is still sorta recognized and transport controls work, but the S88 browser gets stuck on the first instrument it sees in a track and can't be changed :(.

Link to comment
Share on other sites

  • 1 year later...

I solved this by first making sure Komplete Kontrol had all inputs enabled in the MIDI tab, then in Logic go to the Environment page, navigate to the Clicks and Ports layer and make sure the physical input is patched to the sequencer input, for some reason mine was not and now the M32 works perfectly.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...