Jump to content

Weird issue impacting recording and playback


Recommended Posts

With the new M1 in house I am curious about Logic Pro and what it can offer. I have been testing out the "try before buy" for a few days and are experience a strange issue. In between the audio suddenly drops out and the playback restarts from the beginning of the region. The same with recording. Now, I have not been able to recreate this issue in Studio one on the M1. I also tried to monitor the system log through console without finding any correlation to events. This happens also when I'm being inactive and don't do anything in Logic Pro.


Loop of region is used


There was three things I suspected from that and one maybe have an impact, but monitoring the console these "glitches" happens without log events being written.


Log one:

May 4 17:43:41 "My name"-MBP com.apple.xpc.launchd[1] (com.samsung.portablessd.mon[23278]): Service exited with abnormal code: 255

May 4 17:43:41 "My name"-MBP com.apple.xpc.launchd[1] (com.samsung.portablessd.mon): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.


This log is made every 10 seconds.


Log Two:

May 4 01:33:30 "My name"-MBP systemstats[293]: assertion failed: 20E232: systemstats + 413748 [D874F8A4-8CC3-3C32-A0CF-D11198773F69]: 0x0

May 4 01:33:30 "My name"-MBP syslogd[285]: ASL Sender Statistics

May 4 01:33:30 "My name"-MBP systemstats[293]: assertion failed: 20E232: systemstats + 615252 [D874F8A4-8CC3-3C32-A0CF-D11198773F69]: 0x2


This log is made every 10th minute (exact - 1.23.30 / 1.43.30 etc.




I also suspected it to be google chrome helper, but even when this is closed down it does not help.


This happen both at low buffer (64) and high buffer (512)


The setup is as following:


- OWC Thunderbolt dock (TB4) connected to one port in the MBP M1

- Rme FIreface UFX connected to OWC (USB-A)

- Samsung T7 connected to tb (USB-C) on owc (security mode off and formatted APFS)

- Monitor connnected to tb (USB_C)


I also have a USB Hub connected through the USB 2.0 on the OWC, and a Samsung t5 to a tb (usb-c) on the OWC.


Latest driver installed, Mac OS updated


So far I like Logic Pro but small issues like this drives me a bit insane, and possible away from the DAW.


Anyone with similar experience and now a fix for this?



Link to comment
Share on other sites

Loop of region is used

What do you mean?


I apologize for my shady English :) What I mean by this is that the playback is set to loop, so when the playback It reaches the end of region it starts from the beginning of the region.

Link to comment
Share on other sites

Oh ok I see, that's called "Cycle mode". The yellow bar you see in the ruler is the Cycle area.


Now how are you recording exactly? Do you press R? Or click the Record button? Do you have an auto-punch area (a red area in the ruler)?


There are no red area in the ruler. The auto punch in is on (the button with 1234). When I hit record the auto punch drops back to 1st bar and count into where my region starts recording at 2nd bar (as an example). How I activate record depends a bit if I record Midi or Audio. Audio I normally hit R cause of convenience. When I record Midi I normally use the record button in logic or the record on the midi controller.


When I listen to the track I normally activate play through using space.

Link to comment
Share on other sites

Ok well it goes without saying that you should obviously not experience this behavior. Let's try something else. If you create a new user account on your Mac, do you get the same behavior.


Yeah, it is a bit strange. I have been thinking about trying another user account. Just going to eliminate some other things first. I will try and uninstall Samsung ssd software through terminal first since its constantly logging (every 10th second) in system.log even without the ssd connected. Then I will run the ssd without the software. Then for fun I will also try and use my other sound card (Motu) through USB-c just to see if it makes any difference (although my Fireface works fine under Studio one, you never know with Audiogear. Not sure I will be able to do all today, but I report back as soon as I tested these things. Thank you for the help so far!

Link to comment
Share on other sites

Yes that's the kind of troubleshooting, eliminate some variables and see what happens. Do report back, I'm curious to hear your findings! Good luck.


Oke, so the nerd in me has been testing a bit more and I believe I have come a bit closer to understanding the issue.


- Uninstalling the Samsung software did not solve any issues. However, I will run the ssd without the software anyway. "If you don't need it, don't install it".

- I tried setting Mac OS in "Do not disturb" but had no impact. Same errors occur.


I then tried to hook up my Motu M2 to the OWC through the tb (usb-c) port, and so far the glitch has not occurred. I will of course test it over a longer period of time to see if anything happens, but this probably helps narrow down possible errors. At the moment I can think of two possible issues;


1. USB A ports on OWC Thunderbolt Dock might have an issue running a soundcard through, either alone or in combination with Fireface. I could possibly test this by doing two things. Get a firewire to tb (usb-c) adapter and use firewire from Fireface to usb-c on owc, or I could also use a usb-c to usb-a adapter on the Motu to see if hooking it up to a USB A port on the owc recreates the problem (not sure if the last one will work).


2. There might be some sync issue between Fireface and Logic (both are set at 44.1). I think I need to test the Fireface more extensively with Studio One to be absolutely sure the error do not occur there. This could possibly eliminate a driver issue from RME side.


My hope is that I possibly can use Fireface UFX with Logic without any hiccups. I will continue searching but probably have to get some adapters before I know more.

Link to comment
Share on other sites

Or meanwhile you could always at least double-check that it's working as expected without the Fireface connected (using headphones plugged straight into your Mac). But yes my guess is somehow the hub is disconnecting, making the recording stop.


For example here on my Mac if I start a recording then connect my headphones to my Mac during the recording, the recording stops (but playback continues).

Link to comment
Share on other sites

After more testing I think I have narrowed done the problem. So the test I have done so far:


- Yesterday I tested a Motu M2 and that worked fine without glitches.

- I tried as suggested only headphones to the MBP without Fireface connected and that worked fine without glitches

- I Bought a USB-B to USB C cable and connected the fireface to the OWC using that cable. The glitches where back.

- There is a USB 2.0 port on the OWC which I also tested with the Fireface and that glitches too.


- Then I connected the Fireface directly to the mac using USB-b to usb c cable, first without OWC connected. No glitches

- Now I am running Fireface directly into Mac with OWC also connected and no glitches occur.


Based on that I believe both the MBP works fine, and the Logic Pro as well. There also seems to be no error on the Fireface nor the driver.

However, it seems to be issue how OWC is handling USB 2.0, maybe alone or how it communicates with the MacBook. I believe I have enough

to go back to OWC support and ask.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...