Jump to content

Logic REALLY sluggish


303creative
 Share

Recommended Posts

Hi All

I recently upgraded from High Sierra to Catalina (10.15.7) and subsequently to latest Logic 10.6.2 but the programme, as a whole, is sooooo sluggish.

For example, in the Piano Roll if I click on a note it takes up to 3-4 seconds to catch up and sound that note. Same thing if I select another note.... 4 seconds later it sounds. Trying to move notes, change velocities is a nightmare.

I've also noted that in the main window I get so much spinning beach ball I'm thinking of suggesting it becomes an Olympic event - I could get bronze!

This also happens with Core Audio switched off!!!

 

Guy

Link to comment
Share on other sites

is logic checked under system preferences>security & privacy>privacy>microphone? it should be. and am assuming you've rebooted?

 

you can also try resetting the nvram, the smc (google for instructions).

Microphone setting all checked.

Thanks

Link to comment
Share on other sites

I tried pulling out all my component AUs thinking it may be one of them causing the retardation in Logic.

No, exactly the same problem with all plugins removed. I didn't chuck the VST3 ones but am I right in thinking that Logic doesn't look there?

Link to comment
Share on other sites

What is your setup?

My set up is OS 10.15.7, Logic 10.6.2, MacPro 2013 with 64Gb ram. All my drives are SS connected via thunderbolt

Its since I went up to Catalina and upgraded Logic that the probs started.

 

an nvram reset, and/or an smc reset didn't help?

Link to comment
Share on other sites

My set up is OS 10.15.7, Logic 10.6.2, MacPro 2013 with 64Gb ram. All my drives are SS connected via thunderbolt

Its since I went up to Catalina and upgraded Logic that the probs started.

 

an nvram reset, and/or an smc reset didn't help?

Not at all. Sadly.

Maybe it's a call to Apple in the morning?

Link to comment
Share on other sites

I will have to place a call with Apple to get this problem sorted. Thanks everyone for pitching in with possible solutions. You're the best

 

oops, thought you mean that you'd updated the focusrite driver and things were now working ok...

No. I meant Focusrite had been updated a while back and was working fine. Less can be said about Logic at the moment. I can just about use it but the sluggishness is so painful it frustrates beyond belief and I have to calm down with a cuppa!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...