Jump to content

"Logic Pro quit unexpectedly while using __ plug-in" while loading big projects


manaje
 Share

Recommended Posts

I am a professional musician (singer-songwriter/producer) desperately looking for a logic expert to help me troubleshoot this issue that is currently preventing me from working because I'm not able to open up my big logic sessions, as it crashes 90% of time while loading the project, or will inevitably crash at some point if I'm lucky enough to open the project. Here's the issue:

 

Almost every single time I try to open up a big logic session (30+ tracks with several 3rd party plugins being used on most tracks), it crashes while scanning/loading the plugins. The error message that comes up is "Logic Pro quit unexpectedly while using ____ plug-in." There seems to be a set of consistently problematic plug-ins, but just when I think I've understood which plugins it is, it'll crash and list another unexpected plugin as the source of the crash. Often now what happens is it'll crash while loading the project up with a message that says: "Logic Pro quit unexpectedly." and not even list the plugin that was causing the crash.

 

I use the most up-to-date version of Logic Pro X 10.6.2. I am on the most up-to-date version of Big Sur 11.3.1. I run my projects off of an external SSD hard drive. I work on a 2016 Macbook Pro with a 2.7GHz Quad-Core Intel Core i7 processor and 16GB memory. I have 500GB total storage, and I have 90GB available storage. I use a UAD Apollo X4 (fully updated) along with a UAD-2 Satellite. All of my 3rd-party plugins are paid for, legitimate, and fully updated. I don't use any cracked plugins. I mostly use Waves, Soundtoys bundle, Fabfilter, UAD, Softube, Infected Mushroom, AudioThing, TAL, Valhalla, Sonnox, Goodhertz, and Dada Life. That makes up about 90% of the plugins I use. I don't have THAT many 3rd party plugins, but I do use them on practically every track, and I will use sometimes up to 6 3rd party plugins on a given track. I am also using 3rd party plugins on busses and on the stereo out.

 

Things I've tried:

- I've tried reinstalling Logic Pro.

- I've tried moving all the components out of the components folder and into a new folder, then tried moving batches of plugins individually back into the components folder, opened a big logic session, and kept repeating until I could find one of the problem plugins. This didn't work, because the error message would eventually come back while loading up a big project.

- I've tried opening up a small project, individually rescanning/relocating plugins in plugin-manager, then opening up the big projects (which will sometimes work but most often not work anymore). I've tried deleting plugins and redownloading them fresh. This did not work either.

- I've tried opening up an empty project, loading all the seemingly problematic plugins onto a track in this empty project, then opening up the big project I want to open... the big project will usually open now, but as soon I go to close the empty project, everything will crash and close, even the big project.

- Small projects seem to open up just fine, no issues so far. It seems to be only the big projects.

- Even worse, sometimes when I'm FINALLY able to open the project by some miracle (happens less than 10% of time now), it'll crash while I'm playing it back, then I try to reopen, and it'll crash while loading the project once again.

 

Once I am in the project, my CPU meter is typically very high, and at certain moments in the song it'll stop playing and give me the "System overload" message. I am not using ANY midi or software instruments. I am only using audio + 3rd party plugins. I do have flex usually armed on most tracks, as I sometimes like to speed up/slow down the entire song, so I'll flex arm every track and speed the song up, and I haven't bounced out each track individually with the new flexed tempo increase, I'll just keep flex armed on every track and continue working. I'm not sure if that's contributing to high CPU usage or not, but thought I'd mention that regardless. I make sure no other programs are open while I'm working in Logic. My laptop isn't overheating or anything weird like that. If this is indeed a hardware issue, that would revelatory, as I've had virtually no problems in the past with my laptop.

 

I have searched many forums, I even spoke to an old logic tutor of mine troubleshooting for an hour and he couldn't figure out how to help me either. I emailed a logic expert that David recommended to me, but he was honest with me and told me he won't be of much help on this particular issue as I've already tried many of the things he would've recommended to me. I am at a loss for words and my work has come to a complete halt... I am going to be missing certain deadlines. This is actually impacting my life and my income now unfortunately. I don't know what else I can do. I am in DESPERATE need of help with this. I would greatly appreciate any troubleshooting on this. If any logic experts out there are available, I'm happy to pay your hourly rate and troubleshoot ASAP! And if there are any normal Logic users out there that know any work-arounds with this issue or who have any insight at all, your help is very much appreciated. Thanks!

490518324_Screenshot2021-05-04at12_12_23.thumb.png.84455526f8bce55b65cdef01fb8aee7f.png

786277667_ScreenShot2021-05-05at12_21_12PM.thumb.png.02852660c46399ea7d8194c8ef8a9a78.png

Link to comment
Share on other sites

my CPU meter is typically very high, and at certain moments in the song it'll stop playing and give me the "System overload" message. I am not using ANY midi or software instruments. I am only using audio + 3rd party plugins. I do have flex usually armed on most tracks, as I sometimes like to speed up/slow down the entire song, so I'll flex arm every track and speed the song up, and I haven't bounced out each track individually with the new flexed tempo increase, I'll just keep flex armed on every track and continue working. I'm not sure if that's contributing to high CPU usage or not, but thought I'd mention that regardless.

 

You're not only having a high CPU usage, you're just making the project very unstable by doing all this flex stuff in real time.

I suggest you start bouncing in place.

You can always have different project versions if you want to go back.

Flex is not infallible, the more you use it and keep "open" in the project, the more problems you gonna get.

And the 3rd party stuff doesn't help in these scenarios, of course.

 

My 2 cents.

Link to comment
Share on other sites

my CPU meter is typically very high, and at certain moments in the song it'll stop playing and give me the "System overload" message. I am not using ANY midi or software instruments. I am only using audio + 3rd party plugins. I do have flex usually armed on most tracks, as I sometimes like to speed up/slow down the entire song, so I'll flex arm every track and speed the song up, and I haven't bounced out each track individually with the new flexed tempo increase, I'll just keep flex armed on every track and continue working. I'm not sure if that's contributing to high CPU usage or not, but thought I'd mention that regardless.

 

You're not only having a high CPU usage, you're just making the project very unstable by doing all this flex stuff in real time.

I suggest you start bouncing in place.

You can always have different project versions if you want to go back.

Flex is not infallible, the more you use it and keep "open" in the project, the more problems you gonna get.

And the 3rd party stuff doesn't help in these scenarios, of course.

 

My 2 cents.

 

Hey triplets - I will try bouncing out each track in one of my big sessions right now so that nothing is running with flex on it. This is going to be very time-consuming but I'm going to see if it does anything. I suspect something else is still the issue but let's see if this does anything, I'm gonna report back to you. Thanks for the advice!

Link to comment
Share on other sites

 

Hey Presence - just read over this entire thread (thanks for sharing it with me), and it seems there wasn't even really an resolution, just attempted workarounds that were hit or miss?

 

One of the only things on the thread that I read that I haven't actually tried yet was resetting preferences -> audio ....... and then someone else spoke about an issue with iLok plugins... this issue is so ridiculous that people are recommending avoiding 3rd party plugins?! ... I mean what kinda madness is this? This isn't a sustainable solution. So incredibly frustrated. All of my iLok plugins are updated and everything. All of my 3rd party plugins are compliant with Big Sur newest update. There does not seem to be any solution for this, and it seems many others have experienced this with bigger sessions

Link to comment
Share on other sites

The crashing while opening a project is apparently some kind of iLok software issue. Quoted from gearspace -

 

“seems to be related to PACE/iLok protection in their case which seems to corrupt memory leading other vendors' plugins to crash“

 

“ I contacted Fabfilter about it, since their plugins get mentioned in the crash report most often for me. They confirmed it's some kind of cross-plugin memory corruption caused by Pace / iLok, and that they're in contact with several other developers to try and trace it and solve it collectively”

 

I’ve had this happen and it is very annoying the workaround is to open a new empty project, load one of the recently mentioned plug-ins that crashed, close that project and then open the one you were trying but was crashing.

 

At least that way you can open the project but the rest you were talking about I don’t know and it didn’t seem to have anything to do with the project being big or not

 

Try to refrain from pulling out all of your hair :)

Link to comment
Share on other sites

I've had this problem occasionally and I'm afraid I don't have a solution for you, but I can share the workarounds I've used in case that helps. They don't all always work, but usually one of them will:

 

- Load the project with Core Audio disabled, then enable it once the project is loaded.

- Similar to above, but save the settings of the offending plugin while Core Audio is disabled, and remove it, then reinstate it once Core Audio is enabled.

- Disable the plugin in Plugin Manager until the project is loaded, then re-enable it.

- Load a smaller, working project which has the same plugin first, then load the larger project.

- Last resort: load a blank project and then import everything from the offending project.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...