Jump to content

Updated to Monterey 12.1, LPX won't open! HELP!!!! >ADDITIONAL INFO<

Trek Vogel

Recommended Posts

New Years Greetings!


As briefly as possible:


LPX (10.7.2) worked fine this morning.

Late AM, upgraded OS to Monterey 12.1.

Now LPX will not open.

Re-booted machine, nada.

Repeated efforts fail: "Logic Pro X quit unexpectedly. Click reopen to open the application again This report will be sent automatically to Apple."

Two buttons, " OK" and "Reopen" are no help.


What to do? Any help very much appreciated.


Learned of the existence of these troubleshooting modes invaluable. HOWEVER, after reading carefully and applying these steps properly, I am still stuck in the same place.


Interestingly, at one point, having tried these steps repeatedly, LPX appeared to open. HOWEVER, playing yielded no sound. Also, I observed that instrument choice 'Alchemy' on one track was marked with an '!'. May I assume Alchemy is an AU? I also employ Drumcore and Guitar Rig. I am noy the most tech saavy guy. :(


Try as I might, I could not return to this window.


Very frustrating, as I work in LPX every day for hours and I am now dead in the water.


Is it possible to return to previous OS? Would that even help?


Thank you in advance for any help.






Edited by Trek Vogel
Link to comment
Share on other sites



I’m having the same issue. Just updated a few mins ago to 12.1 and couldn’t get Logic to open. After restarting my Mac, my sessions wouldn’t open consistently or if I got one to open, no sound will play. SMH. After forcing Logic to close a few times, I finally got a session to open and play, though still having issues.


I have a two sessions that are identical except for one is using the most up to date iZotope Audio Units (Nectar, Ozone). The session with the iZotope Audio units will not open consistently and when it does it won’t play sound.


Now I’m back to no sessions opening at all…

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...