Jump to content

How to record 2 midi devices simultaneously


Logicman2
 Share

Recommended Posts

I have a Roland FP-3 keyboard daisy chain to 2box drum module then into a Steinberg UR44 midi in. I am trying to record both simultaneously. I am running Logic 10.7.4. Before the update it was simple, Click auto Demix then set drums to 1 and keys to 2 no problem. New update no longer uses auto demix. What is my work around now.

In Audio Midi setup I tried assigning the Keys and Drums to the ports on the Steinberg. Steinberg currently has 2 ports. But that didn't work either. A solution would be greatly appreciated.

Link to comment
Share on other sites

Check preferences->midi->Inputs.

Also preferences->midi->General->MIDI Channel --- is it "Global" or "Per Channel Strip"

Are you trying to record each instrument to different tracks?

Check the midi channel setting in the inspector for each track.

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

4 minutes ago, cleamon said:

Check preferences->midi->Inputs.

Also preferences->midi->General->MIDI Channel --- is it "global" or "pre channel strip"

Are you trying to record each instrument to different tracks?

Check the midi channel setting in the inspector for each track.

Yes I am wanting to record Keys to one track and drums to the other at the same time. In Inspector I have drum set to Midi out 1 and drum to midi out 2. The Midi Channel is Global. Image below

Screen Shot 2022-05-14 at 10.55.47 AM.png

Link to comment
Share on other sites

18 minutes ago, Logicman2 said:

Yes I am wanting to record Keys to one track and drums to the other at the same time. In Inspector I have drum set to Midi out 1 and drum to midi out 2. The Midi Channel is Global. Image below

Screen Shot 2022-05-14 at 10.55.47 AM.png

Have you tried setting MIDI Channel to "Per Channel Strip"?  I'm still on Logic 10.5, so maybe that's changed.  I don't know anything about "Auto Demix".  Never seen it in Logic.  

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

6 minutes ago, cleamon said:

Have you tried setting MIDI Channel to "Per Channel Strip"?  I'm still on Logic 10.5, so maybe that's changed.  I don't know anything about "Auto Demix".  Never seen it in Logic.  

Yes, I have tried everything. I can't figure it out.

Link to comment
Share on other sites

Posted (edited)
30 minutes ago, Logicman2 said:

Yes, I have tried everything. I can't figure it out.

Ok, I've been playing with this.  I did find the "auto demix" setting.  I can get 2 devices on different channels to record, but only to a single track (currently selected track) even though I have 2 channels record enabled.  I think I used to be able to record multiple midi tracks at the same time, but that may have been when I was using Digital Performer.  Maybe someone else will chime in on this.

UPDATE: I was able to get auto demix to work.  Had to set the channel numbers on each track.  
So, auto demix has been removed?

Edited by cleamon

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

6 minutes ago, cleamon said:

Ok, I've been playing with this.  I did find the "auto demix" setting.  I can get 2 devices on different channels to record, but only to a single track (currently selected track) even though I have 2 channels record enabled.  I think I used to be able to record multiple midi tracks at the same time, but that may have been when I was using Digital Performer.  Maybe someone else will chime in on this.

UPDATE: I was able to get auto demix to work.  Had to set the channel numbers on each track.  
So, auto demix has been removed?

Yes Logic removed auto demix with latest update. 

Link to comment
Share on other sites

Posted (edited)
2 minutes ago, Logicman2 said:

Yes Logic removed auto demix with latest update. 

That makes no sense.  Why I wonder.  This is why we have computers!  Have they perhaps moved the setting from Project to Global?
I guess now, you'd have to select events by channel, then cut/paste to another track.

Edited by cleamon

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

26 minutes ago, cleamon said:

That makes no sense.  Why I wonder.  This is why we have computers!  Have they perhaps moved the setting from Project to Global?
I guess now, you'd have to select events by channel, then cut/paste to another track.

Yea, I don't know. 

Link to comment
Share on other sites

It's no longer needed, since midi in port and channel now has been added to the track inspector...

  • Like 2
Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

What JakopP says! Auto Demix has become obsolete since 10.7. Just choose you desired MIDI in port and channel in the track inspector.

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

I guess that's what I'm missing. 10.5 doesn't have MIDI in port in the inspector.  I like this way better.

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

4 hours ago, JakobP said:

It's no longer needed, since midi in port and channel now has been added to the track inspector...

I watched videos on this. When they click on Midi In Port drop down window, they can select what midi device they want to use. I don't have anything in that drop down window except Steinberg port and All. My next step is how to add my midi devices to the Midi In Port to be able to make a selection.

Link to comment
Share on other sites

58 minutes ago, Logicman2 said:

My next step is how to add my midi devices to the Midi In Port to be able to make a selection.

Maybe you watched this one already?

 

Logic Pro 9 Master Pro and X certified - ProTools 10 & 11 Certified Operator
2 x 3.06 Intel Six-Core 24 GB RAM, Logic 10.5.1, 10.14.6., UA Apollo - 2012 i7 MBP 16 GB Logic 10.6.3, 10.15.7
Contact me for Logic help (Teamviewer, Zoom, Skype) - http://www.ultimatestudiosinc.com

Link to comment
Share on other sites

7 hours ago, Logicman2 said:

. I don't have anything in that drop down window except Steinberg port and All.

That would mean you only have a MIDI interface with one port connected to your computer.

  • Like 1

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

Posted (edited)

 

17 hours ago, Logicman2 said:

I have a Roland FP-3 keyboard daisy chain to 2box drum module then into a Steinberg UR44 midi in.

You use the midi in channel, set the drums track to 1 and keys track to 2 ?

Edited by JakobP
  • Like 1
Logic Pro 10.5.1 • OS X 10.14.6 • MBP 15" Early 2013 • 2.4 GHz Intel Core i7 • 8GB RAM • iMac 27 Late 2013 • 3.4 GHz Intel Core i5 • 16GB RAM • Focusrite Saffire 6 USB • cheap midi keyboard • Korg NanoKontrol • Roland UM-One mkII • Behringer FCB1010 • Gibson ES335
Link to comment
Share on other sites

4 hours ago, polanoid said:

That would mean you only have a MIDI interface with one port connected to your computer.

Actually The Steinberg has 2 ports. I tried to assign drums to port 1 and keys to port 2 in Audio Midi Setup and I couldn't get it to work

 

3 hours ago, JakobP said:

 

You use the midi in channel, set the drums track to 1 and keys track to 2 ?

I tried this and it didn't work. 

Link to comment
Share on other sites

2 minutes ago, Logicman2 said:

Yes, Both ports are checked. I don't have the other 2 items though in this window. 

Good.  That tripped me up one time.  And your list of available inputs will depend on your attached devices.

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

6 minutes ago, cleamon said:

Good.  That tripped me up one time.  And your list of available inputs will depend on your attached devices.

I tried attaching the Keys and Drums to the ports in the Audio Midi Setup (Midi Studio window) and I still couldn't get it to work. There's got to be something I'm doing wrong.

Link to comment
Share on other sites

Ok, it just occurred to me, I have a UR242, it has 2 midi ports - 1 for input and 1 for output.  Try setting your tracks to use PORT 1, Channel 1 and PORT 1 Channel 2. 
(again, I don't have LPX 10.7, so I can't try this here.)

 

Logic: 10.5.0 | MacOS: 10.14.6 | iMac (Retina 4K, 21.5-inch, 2017) | Steinberg UR242 | Motu 828MKII FW
Bored out 90 Over with three Stromberg 97's

Link to comment
Share on other sites

Posted (edited)
37 minutes ago, cleamon said:

Ok, it just occurred to me, I have a UR242, it has 2 midi ports - 1 for input and 1 for output.  Try setting your tracks to use PORT 1, Channel 1 and PORT 1 Channel 2. 
(again, I don't have LPX 10.7, so I can't try this here.)

 

This is what I did before 10.7 then I would toggle auto demix.

 

Edited by Logicman2
Link to comment
Share on other sites

Posted (edited)
14 hours ago, Logicman2 said:

I don't have anything in that drop down window except Steinberg port and All.

BTW you should *at least* also have "Off" and "Internal & Remote" as a setting for the MIDI in port. Also, is "Steinberg port" the exact displayed name?

Edited by polanoid

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

1 hour ago, polanoid said:

BTW you should *at least* also have "Off" and "Internal & Remote" as a setting for the MIDI in port. Also, is "Steinberg port" the exact displayed name?

Yes the "Off" and "Internal & Remote" settings are in there as well. I just didn't mention them cause they really don't get used for what I need. The Steinberg Port is the exact display name unless I go into Audio Midi Setup and change the ports 1 and 2 to Keyboard and Drums. 

Link to comment
Share on other sites

1 minute ago, David Nahmani said:

In Logic Pro, if you create a single software instrument track and load an electric piano patch, can you play that patch with the FP-3?

BTW David I just saw, looking at the UR44's manual, that it obviously only has ONE MIDI port (1 in 1 out), so I don't really see the problem anymore... everything seems totally correct on Logic's side

  • Like 1

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

On 5/14/2022 at 4:22 PM, Logicman2 said:

I have a Roland FP-3 keyboard daisy chain to 2box drum module then into a Steinberg UR44 midi in. I am trying to record both simultaneously. I am running Logic 10.7.4. Before the update it was simple, Click auto Demix then set drums to 1 and keys to 2 no problem. New update no longer uses auto demix. What is my work around now.

The only difference with the older autodemix scheme is that now you need only to select the MIDI input port and channel for each track. If that doesn't work, then let us know exactly what behavior you're seeing? 

My new Logic Pro Book is out!

Link to comment
Share on other sites

19 hours ago, Logicman2 said:

Yes the "Off" and "Internal & Remote" settings are in there as well. I just didn't mention them cause they really don't get used for what I need. The Steinberg Port is the exact display name unless I go into Audio Midi Setup and change the ports 1 and 2 to Keyboard and Drums. 

The UR44 only has one MIDI port, see above. If you want to simultaneously record two devices over one port, you need to use the MIDI In CHANNEL, not the port

  • Like 1

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...