Jump to content

Logic 10.7.4 alternative track not menu showing up


geewytee
 Share

Recommended Posts

 

Hey, I'm unable to get the alternative track menu in the latest version of Logic.
This videos shows the problem: https://watch.screencastify.com/v/ze4BOtBy1MlcXIpfAkKP
I use a Macbook Air M1 with Mac OS Monterey

Has anyone encountered this issue? Solution?
Thx

 

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

38 minutes ago, David Nahmani said:

I watched the video again, this time with the sound on, and you're right, that's the issue right there. 

Nope... that's not at all this issue (and of course I do a left click first).

In the video, I mention doing a right click just to show that the menu is not coming up there either.

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

3 minutes ago, geewytee said:

Nope... that's not at all this issue (and of course I do a left click first).

In the video, I mention doing a right click just to show that the menu is not coming up there either.

Oh ok my bad, I misunderstood the video then. 

Ok then what if you try in a brand new empty project, can you make it work there? 

My new Logic Pro Book is out!

Link to comment
Share on other sites

Brand new project alone was. was not cutting it.

I had to open Logic without any project (holding option and double clicking the app icon to open it), then create a new project (and check if the track alternative menu shows up: it does), then open the file I'm working on, which then displays the track alternative.

This means the file is not corrupted.

That's really strange behavior...

  • Like 1

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

If I close Logic and re-open with the project, I have the same issue.

If I reopen without the project, and then open the project, I have the same issue.

I have to open without any project (option key), then create a blank project... and then it works.

 

Basically I have to do the whole procedure mentioned in my previous post every time I want to open the project.

At it it's a consistent bug...

Edited by geewytee

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

 

Okay. This is a sketching file for a couple themes. But I've had that problem with several other files, as well.

Apart from a piano VST, I believe all plugins (instruments and effects) are native to logic.

Here's a G drive link: https://drive.google.com/file/d/17NSQHFXrLjBpxUKuM4L5qNmo5LBR_2TD/view?usp=sharing

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

That project behaves completely normal here, even when I open it, set Logic's startup action to "Open most recent", then quit and restart Logic so the project gets opened automatically. Left-clicking on the Track Alternatives widget immediately reveals the Track Alternatives menu (starting with "New"). All with 10.7.4 on Monterey 12.4

What input device are you using? Trackpad? Mouse? How do you have set your Trackpad/Mouse preferences? E.g. for "Secondary click"?

Do the Key Commands for the various Track Alternatives menu entries still work (like this oneimage.png.87ba5f545696b48aaa28ed59ed0cc97c.png)? 

 

 

 

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

Well, I have to open a blank project before the menu appears in this project.

The key command for new alternative tracks works. But in the related menu I only see the alternatives, not the other functions.

Are you on M1 or Intel?

 

Mac mini 2014 16GB of RAM 250G internal SSD + 250G external SSD | Focustrite 6i6 | Nektar Panorama P6

Link to comment
Share on other sites

11 minutes ago, geewytee said:

My mouse works well in all apps on my M1 MacBook Air

I wasn't questioning that, just wanted to check what could cause this and what's different on our machines. So, M1. I have an Intel Macbook Pro here. And you're using a mouse (or did you want to write trackpad?) Anyone else with an M1 reading this who can check out geewytee's project?

BTW you might want to update your signature ;)

Edited by polanoid

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.3.1 / Logic 10.7.4

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...