Jump to content

Can't get correct first bar


apg
 Share

Go to solution Solved by volovicg,

Recommended Posts

Somehow I have this truncated first bar, which I don't want at all.  Also, bar 0, where the percussion comes in with 32nd notes, should be bar 1.  Any suggestions?

 

This is nearly 2 GB, but the max size is 1.95 MB, so I can't attach it.  I'm compressing it to a zip, but it's taking a long time.  Is there a faster way?

Link to comment
Share on other sites

Maybe a screenshot would help to better understand your problem?

iMac Pro 27 | 3.2 GHz 8-Core Intel Xeon W | 256 GB RAM | Radeon Pro Vega 56 8 GB Graphics | Apollo x8p Audio Interface | Monterey OSX | Presonus Quantum 2632 | Celemony | ReVoice Pro | Cubase | StudioOne | Logic 10.7

Link to comment
Share on other sites

I sorta fixed part of the problem.  If you look at the screenshot, you'll see that it says, for example, 2 in the editing screen while it says 1 up above.  The 2 is correct.  If I can get them synched, that'd be great, but it's no big deal.  The other issue is that the first "piece of a bar" with nothing but rests, should not be there.

 

Thanks.

Screen Shot 2022-06-24 at 9.11.31 PM.png

Link to comment
Share on other sites

I believe your problem exists because of the lead in measures before your 1st bar. You need to grab the start marker in the upper left corner of the project window and pull it to the right so that everything starts on the first bar.

Hover over the small triangle pointing to the right until the mouse cursor turns into a right bracket with a right and left arrow to either side and move it to the right until it aligns with the 1st bar.

See the screenshot and view the attached video. This should resolve your problem.

1718907027_ScreenShot2022-06-24at11_03_12PM.png.e5a67b8fb633280f211f5d57e60e6182.png

Hope that helps

 

Edited by Maestro777

iMac Pro 27 | 3.2 GHz 8-Core Intel Xeon W | 256 GB RAM | Radeon Pro Vega 56 8 GB Graphics | Apollo x8p Audio Interface | Monterey OSX | Presonus Quantum 2632 | Celemony | ReVoice Pro | Cubase | StudioOne | Logic 10.7

Link to comment
Share on other sites

The best thing to do is don't start at bar 1 and never use bar 0. Have your downbeat be at bar three and use bars 1 and 2 for count off. This will solve a lot of problems. 

The only time I'd use bar 1 is if I was using the arrangement features and having drummer follow the arrangement form. Then you need to use bar 1 but I usually avoid it for anything other than automation settings. 

  • Like 1

Mac Studio Max, 64gb ram, OSX 12.1.3
Logic 10.7.4
http://www.ka-music.com

Link to comment
Share on other sites

5 minutes ago, guavadude said:

The best thing to do is don't start at bar 1 and never use bar 0. Have your downbeat be at bar three and use bars 1 and 2 for count off. This will solve a lot of problems. 

The only time I'd use bar 1 is if I was using the arrangement features and having drummer follow the arrangement form. Then you need to use bar 1 but I usually avoid it for anything other than automation settings. 

I agree with that advice, but I think since he just wants to get his score in sync; setting his marker to bar 1 in this case should fix the immediate issue.

  • Like 1

iMac Pro 27 | 3.2 GHz 8-Core Intel Xeon W | 256 GB RAM | Radeon Pro Vega 56 8 GB Graphics | Apollo x8p Audio Interface | Monterey OSX | Presonus Quantum 2632 | Celemony | ReVoice Pro | Cubase | StudioOne | Logic 10.7

Link to comment
Share on other sites

I'd select ALL and slide the midi over to bar 5. Then use the cycle and select from the beginning to bar 5 and use the Edit "Cut Section between Locators" command. That should move everything back to bar 1 and hopefully fix your issue. 

Save the session first before you try this. 

 

Mac Studio Max, 64gb ram, OSX 12.1.3
Logic 10.7.4
http://www.ka-music.com

Link to comment
Share on other sites

I don't know why Logic lets you have negative numbers because I've found they never work. The whole sliding around where bar 1 is to me is a very bad idea. I don't think other DAWS have this. I struggled with this a LONG time ago when I first started using Logic. 

As mentioned previously, I start all sessions at bar 3 and set the sync timing so that 01:00:00:00 is bar 3 start time. Makes it easy to time out 30 and 60 second spots if needed. 

 

Mac Studio Max, 64gb ram, OSX 12.1.3
Logic 10.7.4
http://www.ka-music.com

Link to comment
Share on other sites

That's not doing it.  When I want to execute a cut, it asks if I want to add a bar of 1/4.  Whether I say yes or no, it puts the extra bar back in.  Thanks, very much.  I'll look some more into it tomorrow.

Link to comment
Share on other sites

Never start any MIDI directly on 1 1 1 1 - it just creates problems. Since 23 Years at least, that's when I started using Logic.

Start your piece (like already suggested) at bar 5 or bar 9. Then make sure you give ample pre-roll (start playback from bar 4 or bar 8.

And also when bouncing: Bounce well ahead of your first bar of music. You can always cut off the silence when you or the mastering engineer goes over your tracks.

Good Loops - Guitar Kitchen Vol. 1 - Flexible acoustic guitar loops library

Link to comment
Share on other sites

5 hours ago, apg said:

Thanks, but I tried dragging the start marker, and it didn't fix the issues.  It wouldn't drag any further.

You cannot drag the project start beyond the start of the first region.

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

7 hours ago, apg said:

If I can get them synched, that'd be great, but it's no big deal.

AFAICT the only way to „sync“ them would be to Select All in the Tracks Area and drag everything a bar to the right, and then drag the project start to the right as well. You may also try to define a 1 bar locator range before the start of the first region (you might need to drag the project start further left to accomplish this) and use the Insert Silence function, instead of selecting and dragging everything.

Edited by polanoid
  • Like 1

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

18 minutes ago, David Nahmani said:

Yes, that's exactly what needs to be done here. 

Be aware though that Select All may not select everything (e.g. Regions on hidden tracks and on invisible track alternatives come to mind) so the Insert Silence method might be safer

MacBook Pro 16'' 2019, 2,4 GHz 8-Core Intel Core i9 64 GB 2667 MHz DDR4 / macOS Monterey 12.4 / Logic 10.7.4

Link to comment
Share on other sites

I appreciate everyone's input, but the main problem is that first bar, with the 3 rests, that shouldn't be there at all.  I don't think any of the above suggestions addresses that, but unless someone has a very simple fix, I'm just going to leave it.  Thanks! 

Link to comment
Share on other sites

So you're not talking about playback but purely about the notation and you want to see a pickup bar with just the 32nd note in the score?

Then you need to drag the left hand corner of the MIDI region that contains the pickup note right to the pickup note. I think then Logic doesn't show the rests. But I only do notation in Logic every now and then...

Edited by wonshu

Good Loops - Guitar Kitchen Vol. 1 - Flexible acoustic guitar loops library

Link to comment
Share on other sites

That's not quite right, but thanks, I am using MuseScore for the notation, but I wanted Logic to look more like the MS to make it easier to make some changes in both if I need to.  In any case, I'm moving on.  Thanks!

  • Like 1
Link to comment
Share on other sites

  • Solution

There are two issues -  the start marker needs to be set to 1,1,1,1 and the region needs to be shortened to exclude the automatic rests and only show the pickup notes.  

Here is the process to make the project as small as possible  - then if you can zip and upload - and I can take a look and fix it.

Open the Project Browser ( or just Press F ) - Make sure Project tab is selected. 

Edit -> Select unused - then press delete.

Then go to  FIle->Project Cleanup ( from the main header) - make sure all 3 items are checked.

You will then get a confirmation with all the audio files to delete listed - Press OK.  

Save the project - zip and upload. 

 

Also here is a visual on the issue - I duplicated your situation and then showed how to correct. 

1/ deleted an region or meta data in front of the primary region

2/ Cmd to select all regions

3/ option + right arrow to move everything to the right 1 bar ( based on nudge value)

4/ Trimmed start of the region to eliminate rests.

 

LPH Issue1.gif

  • Like 1

 Logic Pro X Certified : Logic Pro X 10.7.4: 10.8.1 (beta) OS X 12.4 (Monterey) | 2018 Mac Mini 3.2 GHz Intel Core I7 : 32GB Memory : 2-1TB SSD ; 4 Drobo's 48TB combined | MacBook Pro (16-inch, 2019) - 2.3 GHz 8-Core Intel Core i9 | Presonus StudioLive 16 Series III (Digital Audio Interface and Control surface for Logic) | Roland FR-8X : Roland A-PRO ; Ketron SD-90 ; I-Connectivity Mio XL Midi Hub/Router (Networked),  Behringer BCF2000, BCR2000, Novation Zero SLKMKII, Steinberg UR816C Audio Interface

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...