Jump to content

Logic ignores midi channel 10


olavsu1
 Share

Recommended Posts

Hello there,

what instrument  you hear in track 9  when you import these  files.

A: https://n6ges.eu/adler1.mid

B: https://n6ges.eu/adler2.mid

Version A is unchanged.  in Version B  track 9,  I  made  convert ->  separate by  midi  channel;  export all tracks to midifile  and reopen.

Am I the only one with Version A  track 9 playing the wrong instrument (steinway)? Or what's wrong that I can't import midi files correctly?

Thanks.

I but them as attacments too

adler1.mid adler2.mid

Edited by olavsu1
there must have been very fearful people here who are afraid of links.
Link to comment
Share on other sites

adler1.mid is Standard MIDI File format 0, i.e. single track file format. This format is used if you export one single track of MIDI from Logic. There will be no information about the instruments used in the file, so all tracks will be assigned to the same default instrument.

adler2.mid is Standard MIDI File format 1, i.e. multiple track file format. This format is used if you export more than one track of MIDI from Logic. Upon import, Logic tries to find appropriate channel strip settings for the exported tracks, from the info stored in the file.

So, if you want that, you will need to always export at least two tracks at once to force Logic to use SMF 1

  • Like 1
Link to comment
Share on other sites

ahah, adler1.mid  is not exported from logic. it are downloaded somewhere internet.

and originally isn't single track file. it is multitrack and should be arranged using Jammer pro 6 program.

I should also have such midi files where all the instruments are compressed on one track and DAW also displays them as one track.

Let's ask in a different way. how to understand that a midi file received from somewhere is midi0 or midi1?

Edited by olavsu1
Link to comment
Share on other sites

47 minutes ago, David Nahmani said:

You can use the command File in the Terminal: 

Screen Shot 2022-11-08 at 7.51.31 AM.jpg

Thanks.

It's using 1 track  but showed as multi track, isn't that weird and confusing.

Then it's still a bug that Logic  (and  Garageband too) can't detect the right instruments like midi-editors of other operating systems (sonar, anvil studio, rosegarden) can.

Really, never encountered such a problem in other operating systems.

Now  I need automate  these operations:

10 hours ago, olavsu1 said:

convert ->  separate by  midi  channel;  export all tracks to midifile

There are many of these files. to manually do this with all of them one by one... would take forever...

edit: VLC  opens these  files without any problem, all instruments sound correct.

Edited by olavsu1
Link to comment
Share on other sites

20 minutes ago, olavsu1 said:

It's using 1 track  but showed as multi track, isn't that weird and confusing.

I can see why it would appear weird and confusing, however it is the expected behavior. 

MIDI Files can either save all notes (from all instruments) on 1 single track (format 0) or on individual tracks (format 1). When a sequencer (like Logic) imports a MIDI file format 1 it shows the individual tracks as they were saved in the MIDI file, and when it imports a MIDI file format 0 it recreates individual tracks based on the MIDI channels of the notes (so one track for each MIDI channel). 

The advantage of the MIDI file format 1 is that it allows you to have separate tracks on the same MIDI channel, which cannot be saved in a MIDI file format 0. 

Now here in adler1.mid you have your different instruments on different MIDI channels (all on the same track inside the MIDI file, but individual tracks recreated by Logic upon importing). The issue is with track #9, the drum track: its program change (which determines which patch Logic loads on that track) is #0 (Grand Piano), even though the notes are on MIDI Channel 10 which is the standard for the drum track. 

Now why Logic doesn't automatically loads a drum kit patch for MIDI Channel 10, I'm not sure.

Link to comment
Share on other sites

2 hours ago, David Nahmani said:

The issue is with track #9, the drum track: its program change (which determines which patch Logic loads on that track) is #0 (Grand Piano), even though the notes are on MIDI Channel 10 which is the standard for the drum track. 

He (Logic) should ignore this piano in that case.

now attched file is midi1.   Nimeta.png.cfc6add5949091d646f180f3b7835b85.png

Sonar shows  that,  patch is "grand piano" (red box in image) but it plays drums(channel is 10). Logic too plays drums now.

The problem is opening midi0 files  and there is no problem with midi1 files.

 

037-klar.mid

  • Like 1
Link to comment
Share on other sites

I also confirm it as well - automatic instrument selection based on channel designation is not working for ch 10 in format 0. 

Edit: David - I wish they would go back and allow for the importing of midi format 0 as a single track as they did in older version and allow for key a command on input to provide the automatic option to separate by midi channel or not - similar in how they do today in allowing for midi assignment to internal S.I. or to external midi tracks. 

Edited by volovicg
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...