Jump to content

MIDI connected but no input

Go to solution Solved by Jordi Torres,

Recommended Posts


I am recently having some issues using my Roland Juno-DS88 as a midi controller after updating from macOS 10.10 to 10.13. I uninstalled the old version of the Juno-DS driver and installed the appropriate one for this macOS according to the instructions: https://www.roland.com/global/support/by_product/juno-ds88/updates_drivers/cbba5cb6-245f-405a-9437-c74aeead76d3/ 

The midi device seems to show up properly in "Audio Devices".

When I open Logic Pro X (version 10.7.7), the midi interface is recognized and is says 'Now 2 inputs and 2 outputs are available'. But there is no input/sound/recording of software instruments. The built-in computer MIDI works.

I tried but couldn't figure out how to delete/"forget" the Juno-DS midi controller in Logic, then re-install/re-configure. Maybe there are still some remnants of the old driver/settings in Logic?

How can I fix this, short of restoring Logic to factory settings?

Link to comment
Share on other sites

  • Solution

Hi gretzkydra11,

There's something that does not add up with the info you've provided:

6 hours ago, gretzkydra11 said:

after updating from macOS 10.10 to 10.13...when I open Logic Pro X (version 10.7.7),

macOS 10.13. That's High Sierra from back in 2017. Logic 10.7.7 requieres minimum macOS 12.x (Monterey). Could it be you meant you're running macOS 13.x (Ventura)?



  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...