Jump to content

SLCompact Automap 3.0 problem: Logic can't setup correctly


Nic-o

Recommended Posts

Hi,

 

I've just bought a copy of Logic Studio 8 and a Novation Remote SL Compact 25 with the latest software updates. I can't get it to work properly with Logic.

 

The keyboard itself is working fine and I have no problems using Automap with the supplied copy of Ableton Live Lite nor with Reason 4.0.

 

Here's the problem: when I scan for MIDI controllers Logic can't recognize automatically the SL Compact (as it should do according to the manual) and when I manually install it, Logic shows its manufacturer as "Alphatrack", and Automap doesn't work!

 

Am I the only one?

Help plz!

N

Link to comment
Share on other sites

Logic does not see the SL as a midi deviceif you are using Automap 3 it uses HUI to control Logic

open the HUD for automap 3 and click on the DAW setup guide, go to setup for logic and it will show you how to setup HUI as the profile for the SL.

If it does not show up then check that you have setup the sl as a midi device on the mac.

Go to applications>utilities>audio midi setup and add it as a device there.

Link to comment
Share on other sites

Here's the problem: when I scan for MIDI controllers Logic can't recognize automatically the SL Compact (as it should do according to the manual) and when I manually install it, Logic shows its manufacturer as "Alphatrack", and Automap doesn't work!

 

No you're not the only one. I recently installed Logic and Automap 3 (standard not Pro though I don't think it matters) on a new Mac, and Logic couldn't find the Remote SL. There's a file on my MacBook Pro called "Remote SL.bundle" which was not present in the same location on my clean install. I copied this over and restarted Logic, then scanned again and it all worked perfectly.

 

I'm not sure what's going on - maybe the file was left out of Automap 3 intentionally, or maybe it was a bug.

 

I think it's worth contacting Novation support to ask about it - I was lucky in that I had a copy of the bundle file from an old install, but new customers do not.

 

Cheers,

 

Maurice

Link to comment
Share on other sites

Out of curiosity, are you guys using the new MkII version of the SL, just released? Those look quite tasty, and I'm itching to see how well they perform with Logic.

 

Sorry, using the old SL37 here - they don't do a 37-key version of the new ones.

Link to comment
Share on other sites

Out of curiosity, are you guys using the new MkII version of the SL, just released? Those look quite tasty, and I'm itching to see how well they perform with Logic.

 

Sorry, using the old SL37 here - they don't do a 37-key version of the new ones.

Yeah, just 25, 49, and 61. But thanks anyway. 8) I'm actually looking at the new Zero. Double-length touch-sensitive faders, and a horizontal slider as well. Big improvements.

Link to comment
Share on other sites

I asked Novation Support to send me the "Remote SL Compact.bundle"...and they sent it to me in an hour!

I placed it in Library/Apllication Support/MIDI Device Plug-ins and now it's working fine!

Thank you Maurice!

N

Link to comment
Share on other sites

I asked Novation Support to send me the "Remote SL Compact.bundle"...and they sent it to me in an hour!

I placed it in Library/Apllication Support/MIDI Device Plug-ins and now it's working fine!

Thank you Maurice!

 

No probs. Did they say anything about why the bundle file wasn't available to you? It seems like a bug to me and I would have expected an updated version of Automap 3 to be made available by now to remedy this. You're the 3rd person I know of (including myself) to have this problem and either they need to update their documentation of start including the bundle!

Link to comment
Share on other sites

No, they didn't say anything about the problem..

well..I think my problem was a bit different because I had that Remote SL Compact.bundle but it didn't work! It all started to work when I replaced the old with the new one they sent me.

mmm.. yes, an update would be great...or at least a new voice in their support pages.

It's frustrating when you follow the instructions and by point 2 nothing works (point 1 was "switch on the SL and open Logic")!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...