Jump to content

I/O buffer setting affects audio (late) when recording


thomas_sylvan

Recommended Posts

Hi- when I record audio on my powerbook G4 through my digi 002 into logic 7 my audio is recorded behind the beat (audibly and visually). I tried recording the click to an audio track and noticed that when I record the click with an I/O buffer of 1024 the click is recorded later than when I record it with and I/O buffer setting of 32. Why is Logic recording the latent signal? Is this normal? My PDC is set to audio tracks, or off, it doesn't make a difference. Software monitoring on or off doesn't matter. The audio is actually recorded late. Doesn't matter if it is recorded through plug-ins or dry. It also doesn't matter if I record to and external drive or the internal one.

 

Is this normal (I thought latency just affected monitoring, not the recording of the signal)? How do I record audio that is in time with the click? Shouldn't the waveform record in time with the click (or at least be close) regardless of the I/O buffer size?

 

Does the Digi 002 have a bug with Logic or something? Where can I download updates to fix it?

 

I'm totally lost on this one and am getting tired of scooting the audio tracks to the left and guessing at where they should be.

Link to comment
Share on other sites

First, the higher the buffer setting the more latency you add. When recording PDC should be set to off, and should really only be turned on when you are mixing.

Do you by any chance have any plug-ins instanciated on the master bus? Any plugs with look ahead will add latency to your signal path, even if they are bypassed.

What is your Click source?

Link to comment
Share on other sites

no plug-ins were in on any busses. It's just that when I play back everything is out of sync, and when I look at the wave forms they are not lined up. I thought DAWs recorded the signal at the correct time and the latency was only what you heard when recording. Therefor when you stopped recording and hit playback everything would be in time. Am I wrong? Isn't this the idea behind the mBox and basically not listening to what the computer processes when recording, but then having it in time when you play back?

 

Why is everything out of sync?

Link to comment
Share on other sites

I don't know if this will work with the drivers that you use with the mbox, but if you go to preferences/audio/drivers there should be a ittle slider there labeled"recording delay." It's been years since I've had to adjust this, but I'm pretty sure I used it to fix a similar problem. there is a whole process to get the excact time you need to set it to according to your setup. I'm pretty sure it's in the manual. Sorry, like I said it's been awhile. Hope this helps

 

 

-Jared

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...