Jump to content

Alesis Control Pad setup issues


tsunchoo

Recommended Posts

so i have an Alesis control pad and Mainstage and i'm trying to control the Playback plug-in to do basic transport functions - Play and Previous and Next Markers..

 

I've read the manual and searched the web, the buttons have been 'learnt' and midi info is being received but only the Play functionality will work correctly.

 

The 'previous marker' and 'next marker' buttons don't seem to do anything although very occasionally (maybe every 20 hits) they 'seem' to work. I say 'seem' because it happens so rarely it's hard to say what it's doing.

 

I 'built' my hardware device in layout using 'drumpads' first and also tried mapping them as 'buttons' to see if that helped.

 

• why does it only seem to allow one button to be 'momentary' - every time i switch it off it switches itself back on when i return to that button.

 

• why do they not flash yellow at every hit?

 

• why do the previous and next markers only occasionally work?

 

• when they do sometimes function and when the button flashes yellow is not synonymous.

 

• does it matter if the pads are mapped as drums pads or buttons?

 

some other points..

 

- it's not a velocity issue cos it registers hits even at very low velocities.

 

- when i had more than one patch in my list (in the left-hand column) it would play (at a lower volume) the sounds from the next patch when it wasn't even on that one.

 

there's a lot of issues here but maybe someone can see some kind of correlation between them.

 

It could be something to do with Alesis and i must admit i haven't read the

manuals of either Mainstage or the Alesis thoroughly.. what i'm trying to do isn't what i would call 'advanced' stuff and i like to try and muddle my way thru

new pieces of kit to check out who 'intuitive' they are.

 

The Alesis otherwise functions normally when used with the EXS24 in Logic but i need to do more than just fire samples. I'm using it with bus-powered USB and my audio interface is a Zed R16.

 

Plus it doesn't seem related to this issue - http://www.axemansplace.co.uk/2007/10/29/alesis-controlpad-problems/

 

any help much appreciated.

 

cheers

Link to comment
Share on other sites

so i have an Alesis control pad and Mainstage and i'm trying to control the Playback plug-in to do basic transport functions - Play and Previous and Next Markers..

 

I've read the manual and searched the web, the buttons have been 'learnt' and midi info is being received but only the Play functionality will work correctly.

 

The 'previous marker' and 'next marker' buttons don't seem to do anything although very occasionally (maybe every 20 hits) they 'seem' to work. I say 'seem' because it happens so rarely it's hard to say what it's doing.

 

 

• why does it only seem to allow one button to be 'momentary' - every time i switch it off it switches itself back on when i return to that button.

 

• why do they not flash yellow at every hit?

 

• why do the previous and next markers only occasionally work?

cheers

 

It's possible that when your Mainstage learned the buttons - that it was also learning a specific velocity on that button. See if you can force your pad to output just one velocity.

 

That could account for the intermittent response.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...