Jump to content

Loops Become Out of Time [SOLVED]


Hwangman
 Share

Recommended Posts

I'm hoping there is a quick fix for this (fairly new user), but in Logic Express, I have recorded a few small bits of audio and MIDI and am looping them multiple times. I notice that after the 2nd or 3rd loop "segment," the loop becomes out of time w/the rest of the recording. When i try to manually line up the loop to the timeline, i can't get it to line up exactly. The segment jumps between ending too early or beginning too late. Is there some setting that i've missed?
Link to comment
Share on other sites

Check your snap settings and make sure your region lengths are consistent with the grid. If a region is just slightly too short it will go out of time when looping. For instance a 1 bar region that is just slightly shorter than one bar will look normal until you start looping it, then the loop will fall farther and farther out of time until you can see it visibly and hear it.
Link to comment
Share on other sites

  • 2 weeks later...
How do i check those settings? I believe you're right, in that the section i'm trying to loop is slightly shorter than 1 bar. However, i've tried messing with every option i know and i can't get it to actually end at the end of bar 1. It's always slightly shorter, which ends up affecting the sound after i loop it more than twice.
Link to comment
Share on other sites

Thanks for the replies. I think i'll need to track down some videos. No luck. I'm admittedly VERY new to this program, but i figured i could play a short part, trim it, then loop. No luck. Nothing i try as far as options will get it lined up. I even tried copying and pasting the main part multiple times but i can't get that to line up or even trim down to the right length. Argh.
Link to comment
Share on other sites

This should be much easier than you make it sound.

 

Click-hold your region. A yellow help tag will pop up. In the help tag, the last set of four numbers is the length of the region you're clicking. If you want that region to loop in time, that number should read "X 0 0 0" where X is the length of the region in bars. If the number reads "X 0 0 1" or "X 4 4 239" or just about anything that does not finish with "0 0 0" then you're in trouble.

 

In that case, use the instructions I gave you before to adjust the length of your region.

 

If that doesn't work, you'll have to explain to us at exactly which step of the process something doesn't work as expected. If you just tell us "No luck" that's not enough information and it's hard for us to help you. If you tell us exactly WHAT does not work, we can help you.

Link to comment
Share on other sites

Thanks David.

 

When i click and hold the region, it says 8 0 0 40. I realize that i need to adjust it so that the ending digit is 0, but i am unable to do that.

 

I have tried setting Snap to "smart" and "bar" and then adjusting the region in the main window. This does not do anything except change the first 3 numbers in the sequence (ex: 7 33 33 40).

 

I also tried double clicking the region to open the Sample Editor. When i do that, i can manually slide the "Region" setting, but i cannot get it to match up precisely. It skips around and i'm unable to have it be at "0" for the end point of the region.

Link to comment
Share on other sites

  • 7 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...