Jump to content

VE pro and Logic Pro - CPU Spikes on single cores


JT3_Jon

Recommended Posts

Hello,

 

First off, I love VE pro and its a life saver of a technology for running large sample instruments in 32-bit logic while waiting for all my plugs to go 64-bit. However, I'm trying to setup a Logic template and if possible, I would love a definitive answer on the best way to run VE pro with Logic pro on a single machine.

 

I just finished a film score project in which I loaded all instruments into separate VE pro servers, as this gives me the most flexibility within logic; as I only have the one instrument on a single instrument track and dont have to worry about having two tracks, one for the midi data, and an aux for the audio separation of individual instruments, as well as the ability to solo/mute individual tracks (in logic if you mute a multi instrument it mutes all midi channels of that instrument, so to solo/mute individual instruments from a multi can be difficult), automate volume directly on the instrument track, etc. Note, when I say "single instrument each" I dont mean articulation, but actual instrument (i.e. flute). For example, I'll load a single kontakt with 8-10 articulations that I switch via midi CC. So dont get confused by my instrument count, as there are many articulations loaded in each instrument, but obviously one articulation is played at a time (usually). :-)

 

Now while writing this project I noticed I was getting large CPU spikes in Logic on my last core while recording new parts, but when I disarmed after recording the CPU load dropped back to practically nothing (odd side note activity monitor never showed these spikes, but when logic cpu's spike you get audio artifacts, so they are my concern). For this project I was running 9 instances of Vienna Instruments Pro in 9 separate VE pro's in 64-bit server, and 4 separate VE pros with Kontakt 3.5 in 32-bit servers, as well as a few EXS instruments within logic. So not a very heavy load by any means for an 8-core 2.93 intel mac pro I would think. The EXS instruments did not exhibit this behavior, only instruments hosted by VE pro. My VE pro preferences are set to use a single core per server since each instrument is in its own server. (on a side note I tried changing this setting but it seems to make no difference). Buffer is set to 2x host. Host buffer was 256, but had to up to 512, which is getting bad for latency when playing. In case it matters, I am outputting all my tracks to bus 1 for global automation, and then run from bus 1 to bus 10 for some UAD bus compression & EQ of the music tracks, and then to my output 1-2 for ARC monitoring. I've tried bypassing these effects and it seems to have no effect on the CPU spikes. (UAD is NOT in live mode).

 

As a test I put all my Vienna Instruments from this current project in a single VE pro (9 instruments in one VE pro instead of 9 separate VE pro's for each VI), and the CPU hit in logics meters was better when in record enable. Whats interesting is that the overall CPU seemed the same, but instead of 80% on one CPU, it was loading about 40% on two CPUs. Why is this? Shouldn't it be the opposite effect? I would think logic would load the multi-instruments on a single core, and separate instruments on multiple cores. I'm confused.

 

I'm running a 2.93 8-core intel mac pro w/ hyperthreading turned on in Logic 9.1.3 on OS 10.6.5 w/ 24gb RAM. Are there any settings in Logic or VE pro I can set to use less CPU? Does VE pro use much more resources running multiple servers each loaded with a single instrument vs one large server with multi instruments? I'm going to run more tests when possible, but I would love a definitive answer on the best way to run VE pro with Logic pro on a single machine: run multiple VE pro servers, one for each instrument, or have a couple massive servers, or a combination?

 

I put an email into VSL, but would love some feedback on what other Logic users are doing. It seems CPU balance is still a major problem in Logic, and I'm surprised my 8-core mac pro isn't running more smoothly.

 

Thanks in advance for your help and reply,

Jonathan Timpe

Link to comment
Share on other sites

I know you mean well dbszak, and appreciate the reply, but as I stated in my long (perhaps too long) thread that I did change my buffer to 512 and thats starting to have adverse effects on my playing due to latency.

 

My problem is a little more advanced then that, thus the long post, and was hoping for a more advanced answer. Again, no offense dbszak and I do appreciate the post. Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...