Jump to content

Straight Forward Record Cycle Query - not priorly been asked


Recommended Posts



My problem is that once i set a cycle to record, I like to go to the MIDI region of audio instrument that is being recorded (via bussing its output to print on an audio channel) and say maybe mute one or two notes each time it cycles but everytime the cycle starts over whilst recording, the MIDI region is deselected i.e. I cant see the notes in the panel roll unless I re-select the region. Thus my method becomes un-usable when the cycle is short. Is there anyway to combat this?


… and yes I know its a silly way of working but I find it helps writers block immensely :P


Regards Sam.

Link to comment
Share on other sites



Which version of Logic? Please add your Logic version and system info to your signature: Read Me Before Posting - Forum Guidelines (#5)


I tried your technique, it does not deselect the region for each pass of the cycle, however the instant I mute notes in the Piano Roll, all of the notes disappear until I record more notes - then I can again see all the notes (including the old ones and the muted ones) when a new cycle pass begins.

Link to comment
Share on other sites

apologies, I added it after posting this topic thinking it would automatically update the posts I had previously made. I was wrong :(


Okay... say I have a software instument track outputting to bus 1 and an audio track that has bus 1 as its input (bus 1 has no output)


on the software instrument track I have a midi region


I then set up a 4 bar cycle.


I then go to my audio track, record enable it and hit record.


I can now see the waveform being printed on the audio track.


I then select my midi region and open up the piano roll... it displays all the notes in the midi region.


BUT as soon as the playhead reaches the end of the cycle and starts a new "pass" (I have create take folders selected in my project recording settings) I lose sight of the midi notes in my piano roll (Im not sure if the region is actually de-selected as such). They only re-appear if I click on the midi region again.


Thanks again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...