Jump to content

Lion not saving Aggregate Devices? [SOLVED]

Recommended Posts

Never had problems with Aggregate Devices under Snow Leopard - created them, quit Audio MIDI Setup - job done.


Recently got a new machine with Lion (10.7.2) preinstalled, and have noticed that any Aggregate Devices I create now are not being saved. They work without issue once they've been created, for that day's session - but once the Mac has been shut down and restarted, nada.


(In case it had anything to do with my MOTU Ultralite, I've created other Aggregate Devices (not including the MOTU) for Soundflower and Built-In options. But these aren't available on restart either.)


Anyone else having this issue? Anyone know of a fix?

Link to comment
Share on other sites

  • 3 weeks later...

ok i found out how to fix it... i called apple and the first tech, had no idea what i was talking about. so, she went and asked somebody. finally she told me to do the following; go to hd/library/preferences and type the following in the search bar: com.apple.audio.AggregateDevices.plist

now i had to figure this part out my self: before you delete that plist file, first you must delete the aggregate devices you created. once you have done so, close your audio midi set up and delete the plist file. shut your mac down and restart and create your new aggregate devices. worked like a charm.

one other thing i did do was repair my drive. not sure if that had something to do with it to.

so if it doest work for you try disk repair and do the plist delete file steps again.

disk repair is ran by shuting down your mac and holding command and R (at the same time ) as your mac starts.

select your Language, next select disk utilities and run repair disk.

once you have repaired your disk, on the top left corner hit restart and follow the steps above again.


hope this works for you!

Link to comment
Share on other sites

  • 2 weeks later...

That com.apple.audio.AggregateDevices.plist file does not appear in my HD/Library/Preferences folder* at all! And isn't being created when I set up a new AD - which explains why recently created ADs don't appear on reboot.


And, keeping an eye on that Preferences folder, there isn't even a '.temp' .plist file created.


Hmmm. Maybe this has something to do with having replaced the original HD. I used CarbonCopyCloner to transfer everything to the new HD, and maybe some files went missing in the process?


But Aggregate Devices do still work - just that the .plist is not being created. Strange.


*Or in User Library Preferences folder either

Link to comment
Share on other sites

Problem solved: in the HD/Library/Preferences folder, there is an 'Audio' folder containing two .plist files :





I deleted these and rebooted. (Lion created two fresh .plists on reboot.)


Creating Aggregate Devices now works as expected.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...