Jump to content

BIP mutes the original track, and its CPU use? [SOLVED]


oceantracks

Recommended Posts

Hey guys, when you bounce in place, and Logic mutes the track you just bounced, does that mean the original track, even though it may have plugs ins like an AMP sim on it, are no longer taking up CPU? Or do you still have to dump the plug ins from the track you bounced to regain CPU?

 

Thanks

Tom

Link to comment
Share on other sites

Thanks I've been doing this for years, and then after the bounce, getting rid of the plug in on the track I bounced. If I have to go back fix a guitar part later, I have to get the plug back up, go get the setting I had, etc. Then I got to thinking....wait, I may not need to do that if Logic is freeing up the DSP after the bounce....good news!

 

Thanks again

Tom

Link to comment
Share on other sites

For future reference, muting a track (by pressing the M button on the channel strip) is not the same thing as muting regions. If you want to mute a track and free the CPU usage associated with it, you need to mute the regions on that track. Muting the channel strip only mutes the audio, but the plugins are still using processor power.
Link to comment
Share on other sites

guys to really free the CPU, the plug ins themselves need to be muted..... even if the region is muted, the plugs are still running.... just check for yourself by inserting a space designer on an empty track

 

That is incorrect. The same applies to Space Designer: No audio to process, no CPU load. That's the way Logic works.

 

J.

Link to comment
Share on other sites

Jordito is correct. And you can't mute a plug-in. I'm assuming you mean bypass the plug-in, but that's unnecessary if the regions on the track are muted.

 

just check for yourself by inserting a space designer on an empty track

I did that, and nothing happened. Not sure what to check for? Here's a quick test I just did that you can try for yourself:

 

1) Create a dozen track with 3 space designer on each. Drag audio files or apple loops onto all tracks and loop throughout the project.

2) Press play and look at the Audio meter:

 

1160259964_Picture1.png.b6f02e27eb6a847779978d38d67e76b3.png

 

1) Mute all regions on all tracks.

2) Press play and look at the Audio meter:

 

2138021268_Picture3.png.ef6c388b8e936628de48c66658a0ddfc.png

Link to comment
Share on other sites

yes i meant bypass the plug ins..... maybe my computer works differently from yours guys I don't know... maybe the buffer setting has alot to do with it... I operate on 128 setting most of the time to avoid latencies.... i know if i switch to 1024 or whatever that number is, the CPU will show much less strain , almost nothing in most cases....

 

I just took 2 snapshots... 1st (bottom) is when my project is at a stop..... 2nd(top one) is when i play in the area with no regions

 

 

 

by the way, i am interested to know what that yellow line in the CPU meter shows

716944702_Screenshot2012-11-25at5_13_09PM.png.69bdeb3da4f3b8c8d0e46c00c06423d9.png

1688113134_Screenshot2012-11-25at5_13_43PM.png.998aaec292fb25b042b2654c3b286777.png

Link to comment
Share on other sites

maybe my computer works differently from yours guys I don't know

All computers work the same: as Jordi said, it's just the way Logic was written.

 

maybe the buffer setting has alot to do with it

Nothing to do with it.

 

just took 2 snapshots... 1st (bottom) is when my project is at a stop..... 2nd(top one) is when i play in the area with no regions

Your test is not accurate because there are other things going on in your project. Some of those other things are probably responsible for the CPU activity you're seeing. Open a new empty project and insert thousands of Space Designer plug-ins and your CPU meter will stay on zero.

 

PS: I recommend you double-click that small transport bar CPU meter to see a more detailed Audio/Disk meter like on my pictures - it's more accurate.

Link to comment
Share on other sites

Well David tell me what could be wrong with my Logic... I just opened empty project with one channel and inserted space designer with just default setting, no regions, pressed play... and my cpu meter u can see below... I am sure if i changed the buffer size to the largest, the meter would show nothing...

1761868984_Screenshot2012-11-26at12_42_22PM.png.2c091636a4c13c00e3b006a7647b401d.png

Link to comment
Share on other sites

this is meter when Logic is at a stop, one channel, no instrument, just one space designer with default setting

 

if i turn the plug in off (bypass), then the meter shows nothing

 

i see this everyday, when i turn off some synth or effect, the cpu meter shows less tax

 

and the buffer size has a lot to do with it, just insert the most CPU-taking synth/effect you have, and compare buffer sizes 1024 and 128.... 128 will show more CPU usage...

540379402_Screenshot2012-11-26at3_18_06PM.png.7e21df894aa15e687f9c5b20b1bc1e38.png

Link to comment
Share on other sites

i work with instrument tracks, it auto enables record mode when i select one.....i also work with audio tracks but i dont record audio.... all my audio tracks are not record enabled...

 

i really dont have any CPU issues really.....because i learned how to deal with it.....just trying to get a point across... I have made projects running so many plugins, i was wondering how all this could actually be true just using my laptop.... but I try to conserve CPU where I can, so i could use more plug ins..

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...