Jump to content

Logic and MOTU Midi Express 128 set up advice [SOLVED]


Recommended Posts

hi there


I wonder if someone can help me please as if I had any hair left I'd be tearing it out!


I'm on a new iMac, using 10.8.2 - the latest Mountain Lion.


I used a icon cube mi3 as my midi interface previously. The Icon was plug and play, no issues setting up external instruments, selecting correct ports, all worked fine in the Audio Midi set up window.


I now need more ports and I have tried both a MOTU microlite and a now a midi express 128 but I just cannot get them to work properly.


When setting up in the Audio Midi window of the mac the test does not work properly {clicking arrow on ports I mean by this to make sure they are communicating properly}.


When assigning an instrument to the Motu it all appears fine, captures notes from the instrument, but when playing back Logic it transmits midi on all 8 ports {all 8 green lights are on on unit) . It does not seem to transmit midi note off data and it sends the synth haywire - I have to turn the synth off and then on again to reset sound. Also moving the modwheel resets the sound and cuts it off, but the synth won't play again after that.


I tried 2 MOTU units as I thought the first may be faulty. I have de-installed and re-installed the latest drivers from the MOTU site. Tried different USB cables.


I'm not experienced in the environment of logic but I'm guessing theres something I have to do in there - if anyone could help I'd be very grateful.



Link to comment
Share on other sites

I used a Micro Express years ago. It had Factory presets such as "Sequencer 30 fps" (perfect for use with sequencing software like Logic), "Live Keyboards" etc.


Which preset is your unit set to?


The MOTU manual is your friend as it is well written with plenty of graphics to help the user understand the best set up for their needs.


At this point,

Link to comment
Share on other sites



There are probably a few ways to fix this.


I have set my midi instrument port in the Environment to transmit on the port it is assigned to on the MIDI Express 128.


Go to environment layer and open Instrument inspector and select Port number to Match MOTU Express 128 Port 1, Port 2, etc. - not 'Port ALL'. These Port settings will then appear in instruments' inspectors in arrange window.


See Pics


Hope that solves the problem of transmitting one instrument to all ports.



Link to comment
Share on other sites

Thanks again for the reply and pics. Very helpful although I should have perhaps made it clearer that I have done all this.


All working fine with the icon cube interface. All external instruments ports mapped to the correct interface ports.


But then set the same with the motu and it goes haywire.


When I say I'm not experienced in the environment I should of said I know the basics of how to assign ports etc. It doesn't seem I'm missing something so maybe my version of mountain lion is buggy with the motu drivers

Link to comment
Share on other sites



I misunderstood.


While I am not experiencing what you describe - I do have a buggy driver for my MOTU Ultralite - MOTU agreed there is a problem with that driver since OS 10.8.2. My Ultralite recreates a version of itself in AUDIO MIDI setup every reboot if I leave it on.


However my Express 128 is fine. For reference my MOTU MIDI driver is Vers. 4.1 (11/11/11)


To trouble shoot the range of issues you mentioned:

Is your MIDI input to LOGIC working as expected and only playback goes haywire?


If so, have you tried "Reset ALL MIDI Drivers" in Project>Preferences>MIDI>General



Link to comment
Share on other sites

hi Frances


Yes I have tried resetting all devices too.


To be honest both the Ultralite and the 128 have been inconsistent each time. I don't get your replication issue but they do random things - sometimes it won't record notes, sometimes won't play back etc


I was hoping someone would jump at something I have missed.


The only thing in the MOTU instructions I could not follow was the OMS software which I could not download. I can't install it on Mountain Lion - I don't know if that was old legacy instructions or not and really matters.


The MOTU software I used is the latest downloaded from their site.


Given the icon Cube mi3 worked as plug and play I know I'm not going completely mad.


So I have ordered an ESI job: http://www.esi-audio.com/products/m8uxl/


I'll feedback on that one when I get a chance to plug it in as had enough of things not working and wasting time now with the MOTU's. Ironic considering that I bought that as someone recommended them based on their ongoing driver support.


Fingers crossed the ESI works as there's not many options for 8in/8 outs besides the MOTU.


Thanks for your replies again, Simon

Link to comment
Share on other sites

Sorry you are having such MIDI trouble.


However, I am not sure that buying another MIDI interface is going to be the fix.


There is clearly something wrong in your MIDI chain - have you systematically isolated where that is yet?


You are blaming the MOTU for "sometimes it won't record notes, sometimes won't play back etc".



Have you tried plugging a MIDI monitor into the MIDI input / output chains to see what is going on?

I use free MAC app "MIDI Monitor" from http://www.snoize.com/MIDIMonitor/ to check MIDI paths.



Link to comment
Share on other sites

OMS is legacy software from the days of OS9 and earlier. Thankfully OSX Core MIDI did away with the need for OMS.


I used a MOTU MTPll back in the Legacy era (System 7.5.2 through OS9) with OMS- no problem.


With OSX systems I've used a Micro Express, Fastlane, built-in MIDI on an 828mkll and Track 16- all worked without issues. The Micro Express required some time reading the manual but otherwise simply worked.


Are these new or used MOTU units?


I agree with Francis that buying another interface is not the solution here.


If your MIDI interfaces are new and registered, then contact MOTU tech support. http://www.motu.com/techsupport

Link to comment
Share on other sites

I use the Motu Midi Express XT. Is it the same as the Midi Express 128? I think it is similar, but not sure.




Anyways, it looks as though the 128 and XT both utilize MOTU's free ClockWorks software. You have to create and ID at Motu's site, and then can download the ClockWorks software. (Your probably could install it using the CD that cam with the 128 as well.) After that there are a number of options, but fairly straightforward. For me, I can have one port to control another port and filter MIDI messages and so on. You just track a virtual connector cable in the ClockWorks. For me at least, it works rather well.


Maybe I overlooked something but, just to confirm, you do have the ClockWorks software installed, right?

Link to comment
Share on other sites

All fair comments. The thing is the clockworks software doesn't run with the lower spec motu's.


It's for the XT etc.


I agree it should be plug and play but it hasn't been.


The cube interface was however, I have tried multiple keyboards too to isolate problems but didn't make any sense when I can have 3 devices working on the cube mi3 but not motu.


I personally think its buggy drivers for latest osx. If the new ESI coming today has the same problems then Ill have to work harder to get it sorted!


Thanks for comments and suggestions, ill let you know how it goes

Link to comment
Share on other sites

Ok so I bought this unit, the ESI 8MU XL: http://www.esi-audio.com/products/m8uxl/


No drivers to install, plug and play. Up and running in 30 seconds. Perfect on a quick test last night whilst drunk, and still working perfectly on a further test this morning when hungover. It's a relief to say the least.


I think the drivers are buggy for the MOTU's with the latest version of Mountain Lion, not sure what else it could be.


I followed the MOTU tech support suggestions and still no joy. Setting up devices should not be that hard or frustrating!


Thank you for the advice on here Mr V and Frances, it's greatly appreciated.


Cheers, Simon

Link to comment
Share on other sites

MOTU seem to have problems with the new USB3 ports.

A solution is to use a hub between the Mac and the MOTU.


Here's from another user with a similar problem:





I have just received a reply today from MOTU's Support. They told me that other clients, have reported that it is an issue with the new MacBook Pro USB 3.0 ports. And, in my case, they happen to be right. If I plug a "USB Hub" between the MacBook USB 3.0 Port and the USB MIDI Interface, the "Program Changes" start working perfectly, as it did in my old MacBook.


I still don't know who has to solve the issue: Apple or MOTU.


Thank you for your time Eric!




Mountain Lion+Mainstage+Midi I/O Interface

Link to comment
Share on other sites

Great to hear the problem is solved and no issue with MIDI chain.


I must be lucky that my system is still handling 6 in/out external machines direct on USB with Express 128.


Your iMac is USB 2 Frances hence still working.


I have the late 2012 iMac with USB 3 ports which now explains the issues. Good to know so thanks for sharing.


I wonder if the MOTU is USB 1?


The new ESI interface I have is USB 2 which theoretically is a faster communication link.


USB ports should always be backwards compatible, but think not always the case. My Virus needs a hub in the USB chain to work (averagely!).



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...