Jump to content

Logic Pro X commands/macro + zoom HELP!


jontah

Recommended Posts

Hi guys!

 

Just bought Logic Pro X and switched back from Cubase 7 and loving it!

 

Although I REALLY need to fix the zooming issue I'm having; when pressing down CTRL+ALT or just ALT, I get the "zoom tool" to show up, but when trying to zoom in or out vertically and horizontally with the arrows (CTRL+ALT+left arrow or right arrow or up or down) my screen just blinks, like it's refusing or something. How do I fix this?

 

Another thing I noticed that isn't working is the Force note to legato which I've assigned to SHIFT and +, it always worked inside of logic 9.

 

Another thing I'm wondering about is if there's anyone out there that could fix a macro for me so that instead of Pressing CMD+R and then just enter (which btw doesn't work, the enter also makes the screen just blink). This would be like Cubase and Abletons CMD+D.

 

This would really help speeding up my workflow!

 

I would HIGHLY appreciate your help on this!

 

Thank you ALOT.

Link to comment
Share on other sites

when trying to zoom in or out vertically and horizontally with the arrows (CTRL+ALT+left arrow or right arrow or up or down) my screen just blinks, like it's refusing or something. How do I fix this?

The new commands are Command-arrows. You can customize them or use the Logic 9 preset of key commands by going to Logic Pro > Preferences > Key Commands. You can either search the key command window to learn the new assignments, or use the Logic 9 preset under Options > Presets > Logic 9.

Link to comment
Share on other sites

Another thing I noticed that isn't working is the Force note to legato which I've assigned to SHIFT and +, it always worked inside of logic 9.

Check your key command window.

 

Another thing I'm wondering about is if there's anyone out there that could fix a macro for me so that instead of Pressing CMD+R and then just enter (which btw doesn't work, the enter also makes the screen just blink).

I'm confused: if it doesn't work, why would you want a macro for it? :shock:

 

In any case, repeat then enter works as expected here. Again, check your assignments in the key command window.

Link to comment
Share on other sites

That's the weird thing. CMD+R works, but pressing enter doesn't. The screen only blinks. Same with the arrowkeys! And they are assigned in the commandslist I've checked it several times now.

 

I need the macro since I want to duplicate midi notes as fast as possible, just like in Cubase and ableton. Without having to press enter inbetween everyone!

Link to comment
Share on other sites

Odd! :shock: Same system here and it works as expected...Sounds like it could be some kind of key command conflict... or maybe you're right and it's your keyboard? Do you have another keyboard you could try by any chance?

 

Also maybe have a look under Apple Menu > System Preferences > Keyboard and see if any system wide key command might be creating trouble? And while in system preferences, make sure you don't have accessibility turned on? Just ... things to try. I'm not sure what is going on here.

Link to comment
Share on other sites

Odd! :shock: Same system here and it works as expected...Sounds like it could be some kind of key command conflict... or maybe you're right and it's your keyboard? Do you have another keyboard you could try by any chance?

 

It's weird, it worked perfectly fine with Logic Pro 9 and this apple keyboard that I have.. shouldn't be anything wrong on the keyboard,but seems like a keycommand conflict as u say.. I have no idea what it is tho! it worked the first few times I opened up logic pro x ;S

Link to comment
Share on other sites

Thanks for the tip, but I'm on a hackintosh that I built.. so don't know if this works for that too..

 

edit: OK I solved it! instead of pressing CMD+arrowkeys I changed it to alt+arrowkeys and now it's working!

 

What about my force note to legato problem?

 

edit: weird, changing the keycommand for that too from shift+ to shift + cmd+ worked.. really weird :s

 

The only thing I'm missing now is the macro for quick midi editing, I really want this to work without having to press enter inbetween. I've downloaded the QuickKeys app but I haven't got to set it up correctly.. do you know this program well?

 

At the moment I have the command "CMD+D" set to do the following:

 

1. Repeat after asking user for count. Checked: Prompt for repeat count

 

2. Type Keystroke "CMD R"

 

3. Wait for new window. Set to: Wait for: WIndow, Window name: is, Window Type: Document Window, Window is: foremost, Window State: New

 

4. Type Keystroke "return"

 

5. End Repeat: End repeat loop

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...