Jump to content

Very Blocky Waveforms


Charlemagne
 Share

Recommended Posts

Hi,

 

I'm enjoying Logic X, but compared to 9, the waveforms when zoomed in are REALLY blocky (and they don't seem to update to something with better resolution), especially in the comping view. See attached image.

 

8237576_ScreenShot2013-07-27at3_20_52PM.thumb.png.a1ef2d49b514dafa46bc0f7b394800ce.png

 

Is this a known issue? Makes it almost impossible to do accurate comping / edits.

 

Thanks!

Link to comment
Share on other sites

  • 4 weeks later...

What kind of file are you using: format (PCM wav, aiff, caf? mp3? m4a?), sample rate, bit depth? How was the audio file produced: was it recorded in Logic? Imported from another DAW, another software?

 

And finally what happens if you:

1) Bounce that audio region in place?

OR

2) Place that audio file in a new empty project on a new audio track, default channel strip with default settings, no plug-ins. Set the output of that audio channel strip to a bus. Create a new audio track with that bus set as the input, record-enable it and press record to re-record a new audio file in Logic.

Link to comment
Share on other sites

It's CAF format, 48kHz. All files were created in Logic Pro X.

When I bounce, the same happens, blocky waves.

 

When I open the project content (Show package content) and drag the caf files to a new empty project, the wave is fine!!

Link to comment
Share on other sites

  • 10 months later...

Bump - july 2014

Having exact same problem. Annoying indeed! Tried suggested steps earlier in thread. Does anyone have any news 'bout this bug

 

-------------------

Logic X - latest

MB pro 17" i7

OS Mavericks - latest

Link to comment
Share on other sites

  • 2 years later...

Hi.

 

I found this old thread for a very current (and new for me) problem. I've tried all of the fixes outlined above. I also tried the fix mentioned there:

 

 

No luck. 

 

Is there a fix out there? Starting a new project and will be doing a lot of audio editing.

 

My waveforms look like this:

 

1165424897_LPXWaveform.thumb.png.008ce79e281a018853b780a8b34482bf.png

Link to comment
Share on other sites

I read this old post now and I don't think anyone had mentioned it originally, but it seems to be confirmed in your case gnapier: I'm wondering whether this could be caused by the "waveform zooming" feature of Logic. In your own case, try clicking on the blue waveform button on the top right of your picture, to turn that button off. Maybe the true audio signal on your tracks was recorded pretty cold (low) and the waveform's amplitude is simply magnified with this zoom, which could cause this blocky appearance...
Link to comment
Share on other sites

I read this old post now and I don't think anyone had mentioned it originally, but it seems to be confirmed in your case gnapier: I'm wondering whether this could be caused by the "waveform zooming" feature of Logic. In your own case, try clicking on the blue waveform button on the top right of your picture, to turn that button off. Maybe the true audio signal on your tracks was recorded pretty cold (low) and the waveform's amplitude is simply magnified with this zoom, which could cause this blocky appearance...

Thank you Arnaud. You were spot on! As a test, I normalized a file and voila! the blockiness was gone. Very odd that it was recorded so low in the first place as my meters were sufficiently "hot" during recording.

In any case, thanks!

Link to comment
Share on other sites

  • 4 years later...
Honestly I still think logic has one of the worst waveform displays of all the daws. Pro Tools or even Ableton have much better ones and I really don't get why they haven't done anything about it yet, should be a relatively easy thing to change right? Anybody got any opinion on this?
Link to comment
Share on other sites

Honestly I still think logic has one of the worst waveform displays of all the daws. Pro Tools or even Ableton have much better ones and I really don't get why they haven't done anything about it yet, should be a relatively easy thing to change right? Anybody got any opinion on this?

They have had the code to make beautiful waveforms for years already, however so far they have decided against adding it to Logic. Their priority is to keep a max of the computer resources needed to run a project for the audio engine. My opinion is that it is a sound decision. Pun intended. :lol: But seriously, I agree with their decision.

Link to comment
Share on other sites

Honestly I still think logic has one of the worst waveform displays of all the daws. Pro Tools or even Ableton have much better ones and I really don't get why they haven't done anything about it yet, should be a relatively easy thing to change right? Anybody got any opinion on this?

They have had the code to make beautiful waveforms for years already, however so far they have decided against adding it to Logic. Their priority is to keep a max of the computer resources needed to run a project for the audio engine. My opinion is that it is a sound decision. Pun intended. :lol: But seriously, I agree with their decision.

 

Yeah dude I get it - but they can make it an option I guess. You wouldn't have to use it. It would just make editing / comping etc. way easier on the eyes and would spare me a lot of time. When I was working in Pro Tools I felt like it was much easier to (for example) match rhythm of bg's and lead vocal without even listening all the time.

Link to comment
Share on other sites

Yeah dude I get it - but they can make it an option I guess. You wouldn't have to use it.

Sure they could, but based on my 20+ years being in this game I can tell that if they did, you'd get hundreds of threads like this in forums:

 

Q: Why is Logic having such a poor performance on my Mac? Screen redraws are slow, and when recording multiple tracks at the same time sometimes recording stops.

 

A: Go to Preferences > Display and set "Waveform display quality" to "low".

 

Q: Wow thanks man that worked! Awesome. Logic runs much faster now, much smoother. Why would they even consider making a choice like this? Offering an option that makes Logic run slow and recording stop? Isn't a Pro App supposed to prioritize the actual app's performance rather than shiny objects that seemed geared only to marketing the app?

 

So they have to weigh in this kind of things all the time when making decisions regarding features to implement. In the end I'm sure that with increasing resources on newer computers they'll end up implementing it anyway (perhaps in a switchable way as you suggested) but for now they can't risk to suffer all the bad publicity just because some users forgot to switch off the option while running Logic on last year's Mac.

Link to comment
Share on other sites

  • 2 months later...

#1, soooo appreciate that piece of information David about the reason why waveforms are like that, it makes a lot of sense and makes me a bit less frustrated with the Logic team.

 

#2, not to push back, but isn't the solution to that problem simply to have the default be off for such a setting? Then all of those people won't be posting about their poor Logic performance (due to waveform quality, anyway). Plus, without the option to turn on high quality waveforms, you still get a bunch of people writing on forums about how bad the waveform display is.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...