Jump to content

Audio units have disappeared! help plz :)

Logic lost

Recommended Posts

ok i havent solve dmy problem so im looking for help...


basically, Logic was working fine, no worries. I downloaded n AU plug in for free from Izotopes website called vinyl. It worked fine.

I also downloadd a demo of BFD, it worked fine.


Then I was given a free demo CD of a thing called WAVES Plug ins, which I still have the CD.


I installed that disc and it didnt do much except make logiv always scan for audio units evry time it loaded up. So I asked my college tutor to help and he said search in spotlight for nething called waves and delete it. So I did.


after this, logic loaded up fine but I noticed there was no Izotope vinyl or any of the built in AU plug ins available in my I/O section...


i wasnt bothered because I didnt need to use it.


Then I bought an AU plug in called Absynth. It works fine as a stand alone soft synth. But its not available in Logic in my I/O and nor are any plug ins which are audio units!!!!


I think its because i deleted all files called waves or something.


After posting one topic about this, a decent person suggested I reinstall Logic, so I did. But after reinstalling there are still no AU in my I/O


WHATS GOING ON! Please can someone help me as Logic costed so much to buy and its not even working properly. i now know never to install dodgyu looking discs, but what should i do to get the Audio units back>??????

Link to comment
Share on other sites

The other thing i have tried apart from reinstaling is going on


preferences> start logic AU manager


but none of this seems to help either. Im really stuck on this one so if anyone knows of a solution then please help it would be most appreciated :!:


i have also noticed that if I go into finder and then library and look in Audio folder and then Plug ins all there is is empty folders with the names of each of logics Audio Units.


really frustrating and annoying...

Link to comment
Share on other sites

Don't re-install the whole OS. If Spotlight cannot find your AUs it looks like you deleted them all. Out of interest, do you still have the folder they should have been in?




If they were freeware ones download them again. If they were bought, hopefully you still have some record of the registration numbers etc. If you're lucky the company you bought them from might have a record of your purchase.

Link to comment
Share on other sites

ok...lets start at square one so we know where you are at.


Do you have a folder 'Components' ???


There are at least 2 of them:





If you have these folders, then what is inside these folders??? That can help pinpoint if Logic is not seeing your .compoents (plugins), or if other prob (like folders are empty) need to be addressed.


If you do not have these folders - then in Deleting 'waves' you have deleted all your plug-ins. Full Reinstall is your best option - and after downloading/ buying plugins - Bakup, bakup, bakup (1 external backup, 1 burnt Cd/ DVD of original plugin and SN#, et al)

Link to comment
Share on other sites

I see from the above post that:


There is nothing in those folders


First... lets test Logic


No need to reinstall the whole OS. This is not an OS problem.


Download a plugin (dontcrack.com) - any AU will do

Install/ Put component in your user components folder.



If you do not have that folder - Create it, and put .component in it.


Restart Logic


See if AU (instrument or effect) is visible in dropdown menu of your channel strip (Instrument slot or effect slot)


This will tell us a lot

Link to comment
Share on other sites

listen up, i already said that they are compatible plug ins!!!!


i had izotope vinyl runnin gfine b4 i installed that waves dvd. now none of it works. i have tried reinstalling both logic and each plug in. Im using absynth 4 btw and yes iv got a new intel imac.


so, that said does anyone actually know or have some suggestions for things to try? ive already tried 4 ages with the above suggestions and to no avail. I really nead plug ins so please help a dude out : )



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...